Cannot move camera after changing atmo sensor setting


Chesthair Ascot
  • Branch: Live Branch Version: Windows Pending

The camera cannot be moved with the WSAD keys after the value on an atmo sensor has been changed. The camera will be stuck until the player deselects the atmo sensor.


Steps to Reproduce
1) Click on atmo sensor 2) Click on numerical setting field 3) Type in new value (eg, 123) 4) Press enter (to confirm the parameter being set) 5) Attempt to pan camera using W/S/A/D key Expected result: * Camera moves Actual result: * Camera does not move, and will not until player clicks on another tile to deselect the atmo sensor

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


.... ....

This occurs when manually editing values in a text field on the various physical containers and sensors, such as the weight limit in a Storage Bin.

My first guess is that the input control flow is still on the text box after the dialog window closes as if you were still typing. However, selecting another selectable on the screen fixes the input control back to the camera. It could be more complicated than that, depends on how the UI was designed.

Gameplay fix: click another selectable on the screen. This should unfocus the hidden text box and return control to the camera.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now