Black holes even when game is paused


r8bwp
  • Branch: Live Branch Version: Windows Pending

As title says game will crash with blackholes or just exit even when the game is paused. All the usual fixes tried from update drivers to complete reinstall Run as administrator. No mods installed 5600x 3080 32gb ram 2tb nvme ssd

System.NullReferenceException: Object reference not set to an instance of an object
  at PathFinder.AddPotentials (PathFinder+PotentialScratchPad potential_scratch_pad, PathFinder+PotentialPath potential, System.Int32 cost, PathFinderAbilities& abilities, PathFinderQuery query, System.Int32 max_links_per_cell, NavGrid+Link[] links, PathFinder+PotentialList potentials, PathGrid path_grid, System.Int32 parent_cell, NavType parent_nav_type) [0x0020e] in <1c7e9ccb4aa844e2be4538990aabf98e>:0
  at PathProber.UpdateProbe (NavGrid nav_grid, System.Int32 cell, NavType nav_type, PathFinderAbilities abilities, PathFinder+PotentialPath+Flags flags) [0x00126] in <1c7e9ccb4aa844e2be4538990aabf98e>:0
  at Navigator+PathProbeTask.Run (System.Object sharedData) [0x00016] in <1c7e9ccb4aa844e2be4538990aabf98e>:0
  at WorkItemCollection`2[WorkItemType,SharedDataType].InternalDoWorkItem (System.Int32 work_item_idx) [0x0000d] in <8c239b169b544cce8b8bc7ddd2d09e10>:0
  at JobManager.DoNextWorkItem () [0x0001a] in <8c239b169b544cce8b8bc7ddd2d09e10>:0
  at JobManager+WorkerThread.Run () [0x0001e] in <8c239b169b544cce8b8bc7ddd2d09e10>:0

  at UnityEngine.Debug.LogError (System.Object message) [0x00000] in <72b60a3dd8cd4f12a155b761a1af9144>:0
  at Debug.LogError (System.Object obj) [0x00000] in <8c239b169b544cce8b8bc7ddd2d09e10>:0
  at JobManager+WorkerThread.PrintExceptions () [0x00000] in <8c239b169b544cce8b8bc7ddd2d09e10>:0
  at JobManager.Run (IWorkItemCollection work_items) [0x00000] in <8c239b169b544cce8b8bc7ddd2d09e10>:0
  at GlobalJobManager.Run (IWorkItemCollection work_items) [0x00000] in <8c239b169b544cce8b8bc7ddd2d09e10>:0
  at BrainScheduler+BrainGroup.AsyncPathProbe () [0x00000] in <1c7e9ccb4aa844e2be4538990aabf98e>:0
  at BrainScheduler+BrainGroup.RenderEveryTick (System.Single dt, System.Boolean isAsyncPathProbeEnabled) [0x00000] in <1c7e9ccb4aa844e2be4538990aabf98e>:0
  at BrainScheduler.RenderEveryTick (System.Single dt) [0x00000] in <1c7e9ccb4aa844e2be4538990aabf98e>:0
  at SimAndRenderScheduler+RenderEveryTickUpdater.Update (IRenderEveryTick updater, System.Single dt) [0x00000] in <8c239b169b544cce8b8bc7ddd2d09e10>:0
  at UpdateBucketWithUpdater`1[DataType].Update (System.Single dt) [0x00000] in <8c239b169b544cce8b8bc7ddd2d09e10>:0
  at StateMachineUpdater+BucketGroup.AdvanceOneSubTick (System.Single dt) [0x00000] in <8c239b169b544cce8b8bc7ddd2d09e10>:0
  at StateMachineUpdater.RenderEveryTick (System.Single dt) [0x00000] in <8c239b169b544cce8b8bc7ddd2d09e10>:0
  at Game.LateUpdate () [0x00000] in <1c7e9ccb4aa844e2be4538990aabf98e>:0
Build: U42-514967-S


Steps to Reproduce

Blackholes or game exits even when paused

Player.log

Facility.sav



User Feedback


Have update with the information requested

Sooner or later the game crashes apart from the first  new reinstall which lasted a whopping 4 hours... so i dropped back a couple of cycles to hopefully avoid what was making it crash. the game doesn't last 15 to 20 mins without crashing usually. All my drivers are up to date bios up to date

DxDiag.txt

Share this comment


Link to comment
Share on other sites

I let your save run for a few hours without encountering a crash. Could you describe what you're doing when playing the game or help me find a more reliable way to reproduce it?

  • Thanks 1

Share this comment


Link to comment
Share on other sites

I have just changed my gfx card to a 3080 changed my power supply to a 1000w run memtest aida 64 and heaven formatted reinstalled everything used sfc scannow dism and still games exit on their own...so something in my pc must be screwing everything up. Thanks for trying!!!

  • Thanks 1

Share this comment


Link to comment
Share on other sites

The error definitely points to an issue with the game but it's strange I haven't been able to reproduce it. Could you attach your latest autosave?

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now