Sign in to follow this  

Automation wire rendering layer order disturbed by switching into and out of automation overlay at various zoom levels.


The Plum Gate
  • Branch: Preview Branch Version: Windows Pending

Automation wire rendering layer order disturbed by switching into and out of automation overlay at various zoom levels. This is occurring to parts of the circuit which are out of plane with the camera. Clipped portions of the circuitry are reordered and appear on top of gates.s

20180130203722_1.thumb.jpg.21efbc8b0574411dcf176e53a050a1a0.jpg

Above, without panning around. And below where only part of the circuit was zoomed in on - notice partial rendering layer order. Issue persists on panning around, no adjustments are made - order normalizes when flipping back and forth between the automation layer and normal view at wide zoom levels.20180130203823_1.thumb.jpg.a6cfee2b43bf54136f652f7a8bb20a17.jpg.

Edit: I am unable to reproduce this in a reliable manner. After alt-tabbing out to report this, it only happens when it happens.


Steps to Reproduce
Zoom in on an automation circuit, then switch to automation layer and the right click to exit, automation wires appear on top of logic gates. Zooming out and reentering the automation layer, then exiting it again causes normal render layering to resume. Something triggers this - don't know why it's not reliably reproducible.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug
Sign in to follow this  


User Feedback


There are no comments to display.



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now