DRM-Free Launcher Crash


Luigi3214
  • Version: PC/MAC/Linux Pending

Red Text appears when trying to install the lastest update for Shipwrecked on the DRM-Free launcher saying it was aborted, when I run the game it crashes. Both RoG and Normal DS run, so I assume it has to do with Shipwrecked.LauncherCrash.PNG

dscrash.png


Steps to Reproduce
1. Retrieve the launcher from Humble Bundle. 2. Install all 3 versions, including Shipwrecked. 3. Click the "Run me" batch file to initialize the launcher. 4. Wait for the launcher to try and update and fail. 5.Click "Run Game" and receive an error.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

I experienced this problem a few days ago as I was updating to the latest patch. What I ended up doing was closing the updater by clicking the cross at the left top corner of the window, waiting for a moment, then launching it again. Sometimes, after doing so, I would get the same error on the same file (like, 34 out of 119), sometimes it would make a little progress and then crash on a different file.

By repeating this process of launching, downloading a couple of files, crashing, closing, waiting and relaunching, I eventually managed to download all the files, but not before the updater crashed more than a dozen times. After that the game seems to run ok, although I already witnessed some new bugs in it.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now