The server crashes after 40 minutes, happened since the latest release, frequently shut down


TonyXu258
  • Pending

I try to play with my friends in local network, and the server keep crash frequently after around 1 hour. Could any one help me with that?

Latest test by my self playing in seed ID 1585833923 with the following mods:

  1. Craft Pot [DS, ROG, SW, DST]
  2. [DST]Musha [Stable version]
  3. Myth Words theme
  4. Myth Words character
  5. [API] Gem Core(Now with World Seeds!)
  6. Witching Hour
  7. Boss Indicators
  8. No grass gekko
  9. Simple Health Bar DST
  10. Map Revealer for DST
  11. Quick Pick
  12. Personal Chesters
  13. DST Where's My Beefalo?
  14. Geometric Placement
  15. Infinite Tent Uses
  16. Show Me (Origin)
  17. Wormhole Marks [DST]
  18. Extra Equip Slots
  19. Chinese Language Pack
  20. Display Food Values
  21. Global Positions
  22. Combined Status
  23. Minimap HUD

The logs is in the attachment, 

There are a lot of error message:

  • Could not find anim build FROMNUM
  • Net partial byte (10) out of range [0, 7]
  • Error serializing lua state for entity pigman_witch[107012]

 

server_log.txt


Steps to Reproduce

Latest test by my self playing in seed ID 1585833923 with the following mods:

  1. Craft Pot [DS, ROG, SW, DST]
  2. [DST]Musha [Stable version]
  3. Myth Words theme
  4. Myth Words character
  5. [API] Gem Core(Now with World Seeds!)
  6. Witching Hour
  7. Boss Indicators
  8. No grass gekko
  9. Simple Health Bar DST
  10. Map Revealer for DST
  11. Quick Pick
  12. Personal Chesters
  13. DST Where's My Beefalo?
  14. Geometric Placement
  15. Infinite Tent Uses
  16. Show Me (Origin)
  17. Wormhole Marks [DST]
  18. Extra Equip Slots
  19. Chinese Language Pack
  20. Display Food Values
  21. Global Positions
  22. Combined Status
  23. Minimap HUD

The logs is in the attachment, 

There are a lot of error message:

  • Could not find anim build FROMNUM
  • Net partial byte (10) out of range [0, 7]
  • Error serializing lua state for entity pigman_witch[107012]

 

The final part of the logs are the following: 

[00:47:32]: Could not find anim [invisible] in bank [mushrooms]
[00:47:32]: [string "../mods/workshop-1986923829/scripts/prefabs..."]:146: attempt to index field 'talker' (a nil value)
LUA ERROR stack traceback:
../mods/workshop-1986923829/scripts/prefabs/wh_mushroom_r.lua:146 in (field) fn (Lua) <142-150>
   inst = 106993 - wh_r_mushroom (valid:true)
   cap = 120879 - wh_r_mushroom_picked (valid:true)
scripts/scheduler.lua:177 in (method) OnTick (Lua) <155-207>
   self =
      running = table: 0A818168
      waitingfortick = table: 0A8182D0
      tasks = table: 0A8180C8
      waking = table: 11D2E940
      attime = table: 0A818190
      hibernating = table: 0A8180F0
   tick = 81813
   k = PERIODIC 106993: 0.100000
   v = true
   already_dead = false
scripts/scheduler.lua:371 in (global) RunScheduler (Lua) <369-377>
   tick = 81813
scripts/update.lua:180 in () ? (Lua) <159-238>
   dt = 0.033333335071802
   tick = 81813
   i = 81813

[00:47:32]: [string "../mods/workshop-1986923829/scripts/prefabs..."]:146: attempt to index field 'talker' (a nil value)
LUA ERROR stack traceback:
    ../mods/workshop-1986923829/scripts/prefabs/wh_mushroom_r.lua:146 in (field) fn (Lua) <142-150>
    scripts/scheduler.lua:177 in (method) OnTick (Lua) <155-207>
    scripts/scheduler.lua:371 in (global) RunScheduler (Lua) <369-377>
    scripts/update.lua:180 in () ? (Lua) <159-238>
    
[00:47:32]: Warning: Widget:SetFocusFromChild is happening on a widget outside of the screen/widget hierachy. This will cause focus moves to fail. Is     ScriptErrorWidget    not a screen?    
[00:47:32]: stack traceback:
    scripts/widgets/widget.lua:605 in (method) SetFocusFromChild (Lua) <602-627>
    scripts/widgets/widget.lua:624 in (method) SetFocusFromChild (Lua) <602-627>
    scripts/widgets/widget.lua:624 in (method) SetFocusFromChild (Lua) <602-627>
    scripts/widgets/widget.lua:656 in (method) SetFocus (Lua) <629-665>
    scripts/widgets/menu.lua:83 in (method) SetFocus (Lua) <74-85>
    scripts/widgets/scripterrorwidget.lua:109 in (method) OnUpdate (Lua) <102-119>
    scripts/update.lua:90 in () ? (Lua) <33-129>    

server_log.txt



User Feedback


There are no comments to display.



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now