Sign in to follow this  

majority of workshop mods are unusable


moxxie fanclub
  • Fixed

Bug number 1

I log in, went to my worlds and checked my mods before launching as per normal. I was greeted with this monstrosity1597378813_DontStarveTogether9_30_20214_19_06PM.thumb.png.fcf53a47a9b1891a5f743bd9290c0f6b.png

 

I clicked on the icon next to the feather, and for a while it did appear as if the mods were being updated. However once it was done, nothing has changed. The mods remained unusable.

Trust me when I said, I did everything I could. I even had an experienced server owner helping me and guiding me throughout this process, but our options were exhausted and he suggested I take this issue up to this place, where I'm now filing this bug report.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

First solution

I went to steamapps/common/Dont_Starve_Together/mods and deleted everything with workhshop- in front of some numbers. Didn't work. Repeated that step but in safe mode, didn't work. 

Second solution

More of playing around but I went to steamapps/workshop/content and found every mod ID that matches those "incompatible" mods and copied and pasted it into my dst mod folder. Didn't work.

Third solution

I was given a suggestion that it may have to do with my steam login error, and was urged to make use of a vpn. I live in asia and the server owner that was helping me hails from US. He didn't have any problems and thought that maybe if I routed to US and tried to update it would work, it didn't.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

Side notes: This isn't pirated, I bought this game from the steam store with money (or maybe my friend bought it for me i cant rmb)

Side note no.2: This problem is really, really finnicky. Just a few hours ago, I did solution one with safe boot on and it worked. I played in my world for a while and then stopped to go out for a night walk, i came back and after showering decided to continue my play through. This problem came back to bite me again and thus I tried to remedy it with the exact same solution that had worked before I went out for a little walk. Needless to say, it didn't work. I tried again without safe mode, didn't work.

Bug number 2

Before bug number 1 was a thing, here's another problem that I faced. I've seen this bug reported in other treads but I guess there's no harm in adding my voice to the chorus.

How I encountered it: 

Click on host game and selected a world that I wanna work on. Checked my mods and settings to make sure everything is alright and click on resume world. I get to my loading screen and suddenly...

https://imgur.com/a/AwXyOei (sorry but i exceeded my media limit, gotta use imgur now ;-;)

This is just one of the many variants of problem caused by mods AFTER the hotfix on september 23th. Before that everything was fine, no crashes, no workshop mods being incompatible, just peace. 

Failed solution 1: 

Deleted all my mods from my mod folder and relaunched steam and dst. Didn't work. tried in safe boot, didnt work.

Failed solution 2: 

same as no.1 but I unsubbed from every workshop, then resubbed, didnt work

failed solution3:

a clean reinstallation of dst, then steam and dst. didnt work

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Another side note, im gonna send the client logs in the replies because im limited to just 4.88mb ;-;

pls help

 


Steps to Reproduce

i described evberything in my post 

  • Sad 1
Sign in to follow this  


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

yeah this has plagued me since the waterlogged update came out. i got like 97 mods that i personally like and only 5-6 actually work now. i suffer from the above problems mentions but am way too stupid to figure this out.

 

Edited by Ijkdenem

Share this comment


Link to comment
Share on other sites

Your second issue will be fixed in the next beta hotfix.
The First issue additional logging has been added to try and track down the issue, if you can encounter this bug on the beta after the next hotfix, please open a new bug report with your client_log.txt
Changed Status to Fixed

  • Like 2
  • Thanks 1
  • Big Ups 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now