Jump to content

DST wont launch

  • Pending

I downloaded the game yesterday and when i try launching, for a few seconds steam says that the game is running and but nothing appears, then it just closes itself. Not even a black screen or something. I have tried all kinds of fixes what i could find on forums, including starting it in administrator mode, verifying game files, and reinstalling DXSetup and VCredist in the game files folder. All Drivers are up to date as of today. The windows firewall is not blocking anything either. I tried looking at the task manager when i start the game but i didnt see it appear there either.

My PC config should be good enough to run the game as well, i run a Windows 10 Pro 64 bit, 

GPU: Radeon R7 265 Series

Cpu: AMD A10-7700K Radeon R7, 10 Compute Cores 4C+6G (4 CPUs), ~3.4GHz

Ram: 8GB DDR3 

I tried everything here as well: http://support.kleientertainment.com/customer/en/portal/articles/1201532-game-is-crashing-game-won-t-start-pc-mac-linux-

A weird thing is that the game didnt create a client_log.txt after launching, i dont know if that helps or not, and im gonna include the DxDiag here

Thank you for your help

Steps to Reproduce
After downloading the game and clicking play. Game just didnt appear at all.

User Feedback

Could we get you to ensure that the Windows User Account that you're currently trying to play the game on has proper administrative permissions to read/write the hard drive? 

Should the issue persist, could we get you to go into your documents folder at Documents\Klei\ and delete the contents of your \DoNotStarveTogether\ folder. From there, try launching the game once more.

  • Thanks 1

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...