Sign in to follow this  

Dedicated server failed to start


TheMagmer
  • Pending

As title says, I have an issue with launching a server.

Here's a list of what I've done trying to fix this:

1. Restarting the game/Steam/PC

2. Reinstaling the game

3. Checking antivirus and Windows Defender exceptions (and adding dontstarve_steam.exe and dontstarve_dedicated_sever_nullerenderer.exe)

4. Checking if client_log reappears after deleting and restarting the game (it does)

5. Disabling and reainstalling all mods

And nothing worked.

I dropped client_log and server log from my test server, but problem is on every server i tried to enter.

Can someone smarter than me help me?

 

obraz_2021-10-24_201913.png

edit: Also, sometimes (like today) when this bug occurs, I don't have news displayed in main menu. I don't know is this related somehow, cause sometimes news are displaying properly and still i can't launch any server. And also this error fixes himself from time to time but I naver have any guarantee that it won't happen again next day.

Will reformatting the hard disks help?

image.png.3737d3149770cdfbec113fafe371ee7b.png

server_log.txt client_log.txt


Steps to Reproduce

Starting a world

Trying to fix this

Reading the older posts

Trying to fix this again

Giving up

 

Sign in to follow this  


User Feedback


PC cleaned, problem solved (?)

I hope it will never happen again.

 

edit: it happened again

Edited by TheMagmer

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now