Mac version STILL not working despite fix?


helioboros
  • Fixed

Title. ):

Below is the error I got in question. This is still happening despite other threads saying it's been fixed and I've tried reinstalling it.

Process:               dontstarve_steam [4906]
Path:                  /Users/USER/Library/Application Support/Steam/*/dontstarve_steam.app/Contents/MacOS/dontstarve_steam
Identifier:            com.Klei.Dontstarve
Version:               1.0 (1)
Code Type:             X86 (Native)
Parent Process:        ??? [1]
Responsible:           dontstarve_steam [4906]
User ID:               502

Date/Time:             2018-06-12 20:18:25.458 -0400
OS Version:            Mac OS X 10.13.4 (17E202)
Report Version:        12
Anonymous UUID:        43CC042E-48CB-7C91-C7A9-B7DA4E5EF031

Sleep/Wake UUID:       DDBF42DE-D3FF-442B-B3E0-6560754BE2B9

Time Awake Since Boot: 54000 seconds
Time Since Wake:       470 seconds

System Integrity Protection: enabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries
DYLD_FALLBACK_LIBRARY_PATH=/Users/Soren/Library/Application Support/Steam/Steam.AppBundle/Steam/Contents/MacOS:/Users/Soren/Library/Application Support/Steam/steamapps/common/Don't Starve Together:/Users/Soren/Library/Application Support/Steam/steamapps/common/Don't Starve Together/bin:/usr/local/lib:/lib:/usr/lib
DYLD_INSERT_LIBRARIES=/Users/Soren/Library/Application Support/Steam/Steam.AppBundle/Steam/Contents/MacOS/gameoverlayrenderer.dylib:/Users/Soren/Library/Application Support/Steam/Steam.AppBundle/Steam/Contents/MacOS/steamloader.dylib
DYLD_LIBRARY_PATH=

Dyld Error Message:
  Library not loaded: @loader_path/libsteamnetworkingsockets.dylib
  Referenced from: /Users/USER/Library/Application Support/Steam/*/dontstarve_steam.app/Contents/MacOS/dontstarve_steam
  Reason: image not found

Binary Images:
    0x1000 -   0x4eafff +com.Klei.Dontstarve (1.0 - 1) <F3F65B4D-C3FF-332C-822A-26F73818EF25> /Users/USER/Library/Application Support/Steam/*/dontstarve_steam.app/Contents/MacOS/dontstarve_steam
  0x6b7000 -   0x6fd05f  dyld (551.3) <AEE46C03-FE99-3D3F-9A28-119D4A885857> /usr/lib/dyld

Model: iMac14,3, BootROM IM143.0129.B00, 4 processors, Intel Core i5, 2.9 GHz, 8 GB, SMC 2.17f7
Graphics: NVIDIA GeForce GT 750M, NVIDIA GeForce GT 750M, PCIe
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343531533641465238412D50422020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343531533641465238412D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x111), Broadcom BCM43xx 1.0 (7.77.37.29.1a7)
Bluetooth: Version 6.0.5f3, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: APPLE HDD HTS541010A9E662, 1 TB
USB Device: USB 3.0 Bus
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: FaceTime HD Camera (Built-in)
USB Device: Magic Keyboard
USB Device: Gaming Mouse
Thunderbolt Bus: iMac, Apple Inc., 23.10

 

Screen Shot 2018-06-12 at 8.18.31 PM.png


Steps to Reproduce
Have a mac, try to open the game

Status: Fixed

This issue has been fixed in either a future version or updated in a previous version.


  • Like 1
  Report Bug


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
.... .... .... ....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now