Jump to content

Problem with /anim + autocompilier

Recommended Posts


I never coded anything in my life before yesterday so I'm starting from the bottom knowledge-wise. 

I went through Cheerio's Creature Mod Tutorial parts 1-3. On part 3, I successfully ran the game with the mod spawning the tutorial's bird creature. Then I tried to replace the bird with my own simple Spriter animation to test out the process of adding my own art. At that point, enabling my mod made the cursor unresponsive in the DS window and I had to x out of the window. I did a lot of looking around and thought I finally found the problem: other mods were crashing the autocompilier before it created an anim folder for my animation. 

I've uninstalled all other mods except mine. I was able to generate an anim folder by finding the autocompilier in the Mod Tools program, although it won't do it automatically when I run the game. Also, the only thing in the anim folder is a .zip of my animation, but the anim folder in the Creature Mod tutorial had more/different files, including a .tex and 2 .bin files I think? Enabling my mod no longer crashes the game, but the mod doesn't work. 

I've checked to the best of my ability to make sure everything is named correctly and started over from step 1 on the tutorial multiples times. I changed the modmain file to spawn a Beefalo instead and that works, so it seems like the problem is that it can't access my animation files.

I attached a screenshot of some windows and files. My animation is called "test." Hoping someone can tell me what I'm doing wrong, and why autocompiler won't make an anim folder by itself when I start the game?

Thanks in advance


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...