This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.


[A Fix] Having issues with mods not uninstalling?

Recommended Posts

Rhianna    0

So I was having a issue uninstalling my mods completely from the game. I would unsub from mods I had been subbed to but when I launched the game I had mods that were all named similar. This happened after I clicked "Clean all" in my mod list. I wasn't able to update them or use them.

Previously I saw a "fix" for this which encouraged people to go into the - Steam>Steamapps>Common>Don't Starve Together>Mods - and delete the mods from the file but like many I had the issue of "Need Admin permissions" even though I was currently the admin of my own computer. Nothing I tried worked! It wasn't my firewall, I validated my game, I uninstalled and reinstalled the game completely, I spent about 3 or 4 hours trying to fix my game. So if you are still having a issue with this being it's 05/16/2017 this is the fix that worked for me.

[The Fix]

1) Make sure you are unsubscribed to all the mods through steam workshop.

2) Find out how to restart your computer in Safe mode without networking, for Windows 10 you can just hold shift and press restart in your power down options and it will come up with a screen giving you many different options.

3) Once your computer has been booted into safe mode go to "Steam>Steamapps>Common>Don't Starve Together>Mods" and then you should be able to delete the mods straight from the file. 

4) Once you have done this then go to your recycle bin and empty it. Then you are ready to restart your computer normally.


Once your computer is back up and running I suggest not yet resubbing to the mods but start the game and check your mod list to make sure the mods are gone and then exit out, resub away but give it a moment to download before you launch the game. At this point you should be good to go!

This was a fix for me after trying everything else. I hope that this helps other people who are experiencing the same issue I was because I couldn't find anything that helped that was previously posted.

Thanks all and make sure to spread this word around. Could be a fix many are looking for.



Share this post

Link to post
Share on other sites