Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

loode

Dont starve android 4.0 and higher

Recommended Posts

loode    0

Dont starve must be avaliable for android 4.0 and higher this is not fair

I was wating for the game for 2 months and you say its not for android 5.0 and higher!!!!!!

Share this post


Link to post
Share on other sites