Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

AppleSeed2010

[Bug] invisible inc : hud scale too large (can't play game)

Recommended Posts

Hi,

I just have buy the game this week and i can't play it at all.

The hud scale is too big. Screenshot added to this post.

In the settings.lua, there is a somewhat strange value for winWidth :
 

    table = objects [ 0x00000003 ]
    table [ "winFlags" ] = 16
    table [ "iFrequency" ] = 60
    table [ "bVsync" ] = true
    table [ "winMinPositionY" ] = 0
    table [ "winShow" ] = 0
    table [ "winHeight" ] = 0
    table [ "winMaxPositionY" ] = 0
    table [ "winMinPositionX" ] = 0
    table [ "aspectConstraint" ] = 1.7777777910233
    table [ "width" ] = 1918
    table [ "winMaxPositionX" ] = 0
    table [ "winWidth" ] = 240916080
    table [ "bFullscreen" ] = false
    table [ "winPositionY" ] = 0
    table [ "dx11" ] = false
    table [ "height" ] = 1059
    table [ "sDisplay" ] = [==[1 - PL2409HD 24"]==]
    table [ "winPositionX" ] = 0

When editing this file by hand, bFullscreen is taken into account, but not winWidth nor aspectConstraint. Is there a way to force these to 0 or 1 ? Maybe this will resolve my issue.

Tried to check in the lua code, but...

I'm in linux, dual screen settings. Tried with only 1 screen connected with no better result.

Thanks.

2016-04-18-232550 invisible inc.png

Share this post


Link to post
Share on other sites
 
xxxxxx [has Invisible, Inc.] 20 hours ago 
I'm sorry to hear your situation. I'm on Win7 and I never had your problem.

In case it helps, here are my settings.lua. This is with true fullscreen. Also dual monitors.

table = objects [ 0x00000016 ]
table [ "winFlags" ] = 0
table [ "iFrequency" ] = 60
table [ "bVsync" ] = true
table [ "winMinPositionY" ] = -1
table [ "winShow" ] = 1
table [ "winHeight" ] = 1080
table [ "winMaxPositionY" ] = -1
table [ "winMinPositionX" ] = -1
table [ "aspectConstraint" ] = 1.7777777777778
table [ "width" ] = 1920
table [ "winMaxPositionX" ] = -1
table [ "winWidth" ] = 1920
table [ "bFullscreen" ] = true
table [ "winPositionY" ] = 0
table [ "dx11" ] = false
table [ "height" ] = 1080
table [ "sDisplay" ] = []==]
table [ "winPositionX" ] = 0

My friend has the same problem on Mac, so I hope there is a solution.

Edit: From what I can gather it's a problem that occurs when you have some scaling applied to your desktop resolution. Something more common for very large displays. You could try to disable any scaling and also to delete the .../Klei/InvisibleInc/settings contents to reset any graphic options.

reference:
http://forums.kleientertainment.com/topic/39559-graphics-fullscreen-resolution-broken/

Thanks for the help.

Already tried to delete the settings.lua with no result.
(And tried to delete xorg.conf to start anew.)
I don't have any scaling applied.

Your settings.lua has a "good" value for winWidth.

The problem is the same in fullscreen or window mode.
The start screen is fine except for the mouse bug.
All the other screens screen are stretched.

I don't have any problem with other game or software.

 

Share this post


Link to post
Share on other sites