Jump to content

Server will not start, [S_API FAIL]- Details in post

Recommended Posts

ModIndex: Load sequence finished successfully.    
Reset() returning
[Steam] SteamGameServer_Init (8766, 10999, 27016)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
zsh: segmentation fault (core dumped)  ./dontstarve_dedicated_server_nullrenderer

This is the error I receive when trying to launch my dedicated server from my Arch machine. After much troubleshooting I have narrowed things down a bit. I fully uninstalled steamcmd and deleted the user that owns it. I then recreated the user and reinstalled steamcmd, following one of the many tutorials to install and run the dedicated server as well. When I run the server the first time, the expected results occur - it says that it will not start and requires me to generate a server token. Then I generate that token and attempt to run it again, at which point I receive this error.


I have tried to rule out permissions by both running the server as root as well as adding the original user to the root group. Nothing changed.


The server application does work. For months now I have been running an offline server successfully from the same machine with the same configurations. This error does not appear until I make the server online. The server token does successfully validate, and the process gets as far is launching the game server (SteamGameServer_Init) before finally failing. Thanks to the segmentation fault, I get no further results.


Any ideas what may be the cause of this error? Permissions, ports, libraries, or what not?

Link to comment
Share on other sites

<6>[  221.366403] dontstarve_dedi[662]: segfault at e3ec96ca ip 00000000f6d357d5 sp 00000000ffd646dc error 7 in libcrypto.so.1.0.0[f6cf3000+1fa000]

This is from dmesg, describing the segmentation fault and saying something about libcrypto.so.1.0.0.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...