[Gameplay] - Console command bug


Recommended Posts

Bug Submission:

Category: Gameplay

Issue Title: Console command bug

Issue Description: I have a dedicated server on Citadel, this issue is only on my server there as it doesnt happen if i host localy from my own computer:

What happens is i write in the command c_give and give me for example 20 berries. First time it works as it should and they appears in my inventory. The second time i write exactly the same command (no matter if i swap item kind/ammount) it appears under my mouse instead of my inventory and i can not pick it up or interact of any kind with it. If i relog the item have dissapeared and no one else see that "fake" item on the ground either. After relog i can once again use a console command ONCE then it bugs again and i have to relog.

This is from the log

Here i tried to use the command, twice. it only shows me giving it once thou

[02:32:27]: [Load] SPAWNING PLAYER AT: (127.05, 0.00, 5.00)

[02:32:27]: [Announcement] Fromme has joined the game.

[02:32:37]: [Fromme:KU_EF1HJCdz] ReceiveRemoteExecute(c_give("berries", 20)) @(128.73, 5.53)

[02:32:37]: giving 133551 - berries

[02:32:37]: giving 133553 - berries

[02:32:37]: giving 133555 - berries

[02:32:37]: giving 133557 - berries

[02:32:37]: giving 133559 - berries

[02:32:37]: giving 133561 - berries

[02:32:37]: giving 133563 - berries

[02:32:37]: giving 133565 - berries

[02:32:37]: giving 133567 - berries

[02:32:37]: giving 133569 - berries

[02:32:37]: giving 133571 - berries

[02:32:37]: giving 133573 - berries

[02:32:37]: giving 133575 - berries

[02:32:37]: giving 133577 - berries

[02:32:37]: giving 133579 - berries

[02:32:37]: giving 133581 - berries

[02:32:37]: giving 133583 - berries

[02:32:37]: giving 133585 - berries

[02:32:37]: giving 133587 - berries

[02:32:37]: giving 133589 - berries

[02:32:55]: [Announcement] Fromme has left the game.

Have also tried swapping to c_spawn after i used c_give once but same error happens there. I can start with c_spawn it works once then bugs also.

After the first time an error string appears in console when using exactly the same command as the first working one

[string "scripts/consolecommand.lua"]:312 attempt to index field 'inventory' (a nil valute)

Have hosted several games on my own computer had never a issue there. Only on citadel server and they told me to post it here

I had no mods on the server this happen from the very start

Steps to Reproduce: Use same command twice in console second doesnt work

Link to comment
Share on other sites

Those commands need to be executed remotely. This requires you to push the designated button (default: Control) to toggle the remotedness of the command. if you are not an admin of that server, you can't remotely execute commands.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.