Jump to content

Black screen upon selecting custom character


Recommended Posts

I've been working on making my first custom character using Dleowolf's tutorial, and after hitting roadblock after roadblock, I finally can't get over one. I just can't figure out what to do.

 

I took a break on the art to see if the thing would even work ingame. When I boot up the game, the mod enables with no issues. Everything seems to be in order, until I select the character. Screen just goes dark and I have to close down the game. I let it sit for quite a while so I don't know what's up with it. I checked the log and only thing I'm seeing that I think might be it is

"[00:00:40]: Can't find prefab gale"  I know prefabs are case sensitive. I don't have a single word in any of the luas for my mod that has the name lower case like that. When I tried changing everything to the lowercase (afterwards reverting it back) it just made even more errors appear.

 

What am I doing wrong..?

 

I just don't get it and really want to get back to working on my character..

 

 

 

I'm attaching my log, since the site says I can't upload the rar of my mod folder. log.txt

Link to comment
Share on other sites

I've been working on making my first custom character using Dleowolf's tutorial, and after hitting roadblock after roadblock, I finally can't get over one. I just can't figure out what to do.

 

I took a break on the art to see if the thing would even work ingame. When I boot up the game, the mod enables with no issues. Everything seems to be in order, until I select the character. Screen just goes dark and I have to close down the game. I let it sit for quite a while so I don't know what's up with it. I checked the log and only thing I'm seeing that I think might be it is

"[00:00:40]: Can't find prefab gale"  I know prefabs are case sensitive. I don't have a single word in any of the luas for my mod that has the name lower case like that. When I tried changing everything to the lowercase (afterwards reverting it back) it just made even more errors appear.

 

What am I doing wrong..?

 

I just don't get it and really want to get back to working on my character..

 

 

 

I'm attaching my log, since the site says I can't upload the rar of my mod folder. attachicon.giflog.txt

 

 

Oh, forgot to add my luas. modinfo.lua modmain.lua Gale.lua

Link to comment
Share on other sites

There is not a single prefab with an upper case letter.

 

Keep the prefab as "gale", no upper case letters.

 

If you want uppercase letters for when other people see your prefab, stick to

STRINGS.NAMES.GALE = "Gale"
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
  • Create New...