Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

coreymwamba

(Resolved) Shank 2 on Arch Linux - memory trace/error?

Recommended Posts

coreymwamba    0

Hello,

 

I've just bought Shank 2. I'm on an Arch Linux 64-bit system, and thought that as MotN worked fine [and is a great game!] that Shank 2 would be all right; but sadly it is not loading. I get a black screen and then I'm returned to Steam. I have tried running the game in a terminal, and have attached the output - hope this helps.

 

shank-log.log

Share this post


Link to post
Share on other sites
coreymwamba    0

Hello again - I have solved this myself. 

 

The problem was caused by Steam's version of libasound.so, ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libasound.so.2 - it was this that created all the ALSA lib messages at the beginning of the log I attached.

 

I edited ~/.local/share/Steam/SteamApps/common/Shank 2/bin/shank2 to preload the correct library from my system:

#!/bin/bashcd "$(dirname "$0")"export LD_PRELOAD=/usr/lib32/libasound.so.2 export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib32exec ./shank2-bin $* 

On doing this, the game loads perfectly. If anyone has a problem starting the game (black screen for a moment, then it disappears) it may be worth checking the logs for ALSA messages, and then trying this fix.

 

Share this post


Link to post
Share on other sites