[General] - Press <keybinding> to Disconnect" during server join not working


Scoundreya

Recommended Posts

Bug Submission:

Category: General

Issue Title: Press to Disconnect" during server join not working

Issue Description: After selecting a server from the list and clicking "Join", pressing the keybinding to disconnect or "cancel" loading into that server while it's still loading has never seemed to work for me. This is an issue because sometimes a server just takes too long to load, or never really loads at all (this is usually the case with heavily modded ones) and at that point I'd rather just cancel it and browse the list again. Because of this issue, what I have to do is force close DST altogether and re launch it every time this happens.

I had effectively changed my ESC keybindings to the ` key (the one with the ~ key right below the ESC key) and everything about it works from navigating menus and using it in game except for the issue of this topic. I then switched the keybinding back to ESC, thinking maybe it was my keybinding not being the default that was causing it to not work for some reason but it still didn't work for me when I used ESC.

Not sure if this is really a "bug" or what but I think it could be? I've tried spam pressing both my rebound key and also with the ESC key. I'v tried waiting for 10-15 seconds after doing so and it never disconnects me from the loading screen - It either keeps loading or eventually I get the error that there were too many mods that I don't have.

Steps to Reproduce: 1.) Select a server from the list (preferably one with a lot of mods so it takes a while to load) and join it.

2.) Wait until it gets to the loading screen and has the "Press to Disconnect".

3.) Press your bound key for disconnecting from the server while it's loading.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.