Jump to content

Server outputs exit code 0 without downloading any mods on Linux

Recommended Posts


As an usual user of DST dedicated servers on Linux, I want to point an old odd bug that still happened to me recently (currently on version 562556).

When it comes to set up a dedicated server without mods, everything works perfectly.

When it comes to run a dedicated server with mods already downloaded, everything works perfectly.

Last server I run was on a Debian 12 and on steamcmd docker image (64 bits).

Steps to reproduce:

- setup the server like the original guide

- adding a bunch of mods on `dedicated_server_mods_setup.lua`

- edit a little bit the last lines to only launch server to download mods by :

    - adding options `-only_update_server_mods` and `-ugc_directory`

    - removing option `-shard`

    - adding "echo $?" at the end of the file to print last process exit code

(I have shared the file `run_dedicated_servers_edited.sh`).

- run the script file

What I expect to have:

- server downloads the mods and exit code 0.

What I actually have randomly:

- server logs "success downloading" and exit code 0, without downloading any mods: "ugc_directory/content/322330" directory is empty (file `server_log_failed_exit_0.txt`).

  there is sometimes a mod directory in "ugc_directory/download/322330"

- server downloads everything and exit code 0 (file `server_log_success_exit_0.txt`)


Let me know if you need more information. I'm willing to help investigating that.


server_log_success_exit_0.txt server_log_failed_exit_0.txt


Link to comment
Share on other sites

  • Developer

The logs are pointing to an issue with Steam downloading the mods but not getting the data back within 30 seconds and there are no functions to be able to be used to see what went wrong in this case. After the 30 seconds of no networking the game will shut itself down with this launch option because it assumes the connection is bad. The segfaults will be addressed in the next game update and the next beta hotfix with the engine being shut down more gracefully than it is now.

Link to comment
Share on other sites

I can not recall the launcher waiting 30 secs before shutting down, I feel it was way shorter, I will try again while using `time`.

I have made the tests on OVH instances, where the connection should be stable. I will also try on AWS instances.

Thank you for the quick reply !

I also sometimes have a seg fault exit code 139, with a core dump. But I think that's another issue.core


Link to comment
Share on other sites

Sorry for the delay, here are some news on version 564742:

- on instances AWS & OVH, it downloads perfectly

- actually at home, it still randomly download (sometimes none, sometimes half of it, sometimes all of it), and when it fails, it does still exit code 0... I have tried without firewall.

I have never got any segmentation fault on any of theses tests.

Here are the logs.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...