Jump to content

Modding a custom character - Crash to desktop when clicking on "Host game" or "Mods"


Recommended Posts

Hello all!

I recently started working on my first mod ever, which is kind of a big project with several aspects so I suspect I'll make a couple more posts in the future (assuming I don't lose hope with this project thing...)

On to today's issue: as the title states, I get a CTD when I try to open the Mods tab or the Host game tab in game. I checked the game's log to see the reason of the crash, which seems to be an issue with my modicon.tex file. I replaced it with the default modicon.tex included in the template I used and tested again. This time, I was able to create a game and load it until it crashed at the end of the loading screen, right before the character selection screen appears. The crash log confirmed what I was suspecting, this time the problem was the other .tex files (the nameplates and portraits).

Here is what the crash log thingy says for last crash as described above:

.../character.tex is 491x654 but compressed textures must have power of 2 dimensions.
.../character.tex: The engine doesn't currently support 3D textures. Did you mean to use a 2D texture?

I ran my .png images through TEXCreator to generate the .tex files, and I did make sure it was set to 2D. Seems others have had the same issues too, as I've found on the forum thread for the TEXTools (https://forums.kleientertainment.com/files/file/73-handsome-matts-tools/page/3/). One said using an older version of the TEXTools solved the issue for him/her, but I can't seem to find said older version.

Anyone know what I'm doing wrong? Fellow modders who made custom icons for your mods, how did you proceed? Those of you who made custom characters, have you encountered a similar issue when modding? did you find any solution?

 

Link to comment
Share on other sites

Welp forgive me for speaking too soon, I actually found a solution after doing a bit more research in my mods and digging on the forums. Ran the .png through TEXCreator and set it to 1D this time, all .tex files functional.

Leaving this here in case it ever helps anyone (?)

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...