Sign in to follow this  

Printing Pod / Porta Pod prints on wrong asteroid


JahwsUF
  • Branch: Preview Branch Version: Windows Pending

Certain "care packages" from the Printer Pod refuse to print on some in-game asteroids.

The main "rule of thumb" I've found:  if a resource or seed has not yet been uncovered or obtained on an asteroid, any attempt to "print" a corresponding care package will be redirected to a different asteroid that has obtained that resource.  There is no warning that this will occur.  Pre-cooked food, dupes, and critter eggs do not appear to be redirected.

Here's a recent case.  One of my four offerings from the Printing Pod was a single Wort Seed.

Asteroid 1:  has obtained Wort Seeds

791338056_asteroid1.thumb.png.d65dd41fbb278bd0b1c500be70966eca.png

Note:  Wort Seed - 1 unit.

Asteroid 2:  has not obtained Wort Seeds

1626417023_asteroid2.thumb.png.8e16b46374693c8831292728f574fd56.png

After taking that screenshot, I then used Asteroid 2's Porta-Pod to print the Wort Seed care package.  (Apologies; I forgot to screenshot that part.)  Results:

256671124_post-print2.thumb.png.ce6f8fc67f6ff66c450e95c82951eb7b.png

Still no Wort Seeds!  But, on the other asteroid...

1454514320_post-print1.thumb.png.c31266777e09381d3fbab0aec8e68226.png

Now there are two!  But I didn't ask to print it here!

-----

IF this is intentional behavior, then I still consider this to be a bug - in particular, a UI bug.  The UI should not allow users to think that the care package will be printed here (on Asteroid 2, which has never seen a Wort Seed).  It would be kinda reasonable if this is just a UI bug, as rockets are the intended 'import' pathway, even if I'd prefer not to have the restriction.

My suggestion:  the care package should be greyed out on worlds that cannot print the package.  Consider the use of alt-text to indicate that this asteroid/Porta-Pod is not allowed to print it, but others are able.  Perhaps the alt-text could even list the worlds with permission?


Steps to Reproduce
  1. Achieve a multi-asteroid base.
  2. Ensure a Porta-Pod has been built and activated on Asteroid 2.
  3. Wait for the "New Printables are available" notification.
  4. Save your game.
  5. Save-scum until you are offered a resource or a seed that has never been accessed by a Duplicant on one of the asteroids.  (It may exist on the map if it has never been dug up!)
  6. Attempt to 'print' the care package on the world that has never had access to that resource.
Sign in to follow this  


User Feedback


I had a problem with this as well, but a little different. I looked at the second asteroid but didn't travel there, and my next care package had an Oxyfern seed, which I chose. When I tried to plant it, it kept saying there was no seed available so I found the seed on the resource list. It then appeared by my printing pod, but I couldn't plant it. I had a dupe sweep it into a bin, and then I could plant it from there.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now