[LINUX] Game will not start after update


joelkillspeople
  • Branch: Live Branch Version: Linux Pending

Shows error when running from terminal:

munmap_chunk(): invalid pointer
Aborted (core dumped)

 

strace log attached

The Player.log file hasn't been updated since last month probably because I last played it then.


Steps to Reproduce
Attempt to run :(


User Feedback


Just wanted to bump, this. Is there any further information I can provide which would be helpful?

 

I'm running an PowerColor RX570 with 4GB of RAM, I'm running the following AMDGPU driver:

amdgpu-pro-19.50-967956-ubuntu-18.04

 

I'm running Ubuntu 18.04 with the following kernel:

uname -a
Linux [redacted] 4.15.0-76-generic #86-Ubuntu SMP Fri Jan 17 17:24:28 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

 

ldd shows as follows:

ldd ./OxygenNotIncluded
	linux-vdso.so.1 (0x00007ffe1a1a8000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f47d3efa000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f47d3cf2000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f47d3969000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f47d35cb000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f47d33b3000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f47d3194000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f47d2da3000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f47d40fe000)

I'm attaching an LSHW. This used to work! I've also uninstalled and reinstalled the program. Verified the program. Spoken nicely to the program...

lshw

Share this comment


Link to comment
Share on other sites

Updating again;

I upgraded my kernel, all AMDGPU drivers, etc, and still can't get this to run in Steam Runtime.

 

I decided to run an strace to see what was going on, and I'm seeing that the program crashes with the "munmap_chunk(): invalid pointer" error.

 

I'm going to paste a log file to this as well.

 

[pid 12696] openat(AT_FDCWD, "/sys/devices/pci0000:00/0000:00:07.0/0000:06:00.0/revision", O_RDONLY) = 20
[pid 12696] openat(AT_FDCWD, "/sys/devices/pci0000:00/0000:00:07.0/0000:06:00.0/vendor", O_RDONLY) = 20
[pid 12696] openat(AT_FDCWD, "/sys/devices/pci0000:00/0000:00:07.0/0000:06:00.0/device", O_RDONLY) = 20
[pid 12696] openat(AT_FDCWD, "/sys/devices/pci0000:00/0000:00:07.0/0000:06:00.0/subsystem_vendor", O_RDONLY) = 20
[pid 12696] openat(AT_FDCWD, "/sys/devices/pci0000:00/0000:00:07.0/0000:06:00.0/subsystem_device", O_RDONLY) = 20
munmap_chunk(): invalid pointer
[pid 12696] --- SIGABRT {si_signo=SIGABRT, si_code=SI_TKILL, si_pid=12696, si_uid=1000} ---
[pid 12335] access("/run/user/1000/gdm/Xauthority", R_OK) = 0
[pid 12335] openat(AT_FDCWD, "/run/user/1000/gdm/Xauthority", O_RDONLY) = 113
 

oni.txt

for the record, this is what was upgraded on Feb 10, 2020:

 

Start-Date: 2020-02-10  14:09:10
Commandline: apt full-upgrade -y
Requested-By: obscured (1000)
Upgrade: fdisk:amd64 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), bluez:amd64 (5.48-0ubuntu3.2, 5.48-0ubuntu3.3), libgles2-mesa:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libwayland-egl1:amd64 (1.16.0-1ubuntu1.1~18.04.1, 1.16.0-1ubuntu1.1~18.04.3), uuid-runtime:amd64 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), libqt5test5:amd64 (5.9.5+dfsg-0ubuntu2.4, 5.9.5+dfsg-0ubuntu2.5), libfdisk1:amd64 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), libdrm-nouveau2:amd64 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), libdrm-nouveau2:i386 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), qt5-gtk-platformtheme:amd64 (5.9.5+dfsg-0ubuntu2.4, 5.9.5+dfsg-0ubuntu2.5), bluez-cups:amd64 (5.48-0ubuntu3.2, 5.48-0ubuntu3.3), libllvm9:amd64 (1:9-2~ubuntu18.04.1, 1:9-2~ubuntu18.04.2), libllvm9:i386 (1:9-2~ubuntu18.04.1, 1:9-2~ubuntu18.04.2), libegl-mesa0:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libsystemd0:amd64 (237-3ubuntu10.33, 237-3ubuntu10.38), libsystemd0:i386 (237-3ubuntu10.33, 237-3ubuntu10.38), libglapi-mesa:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libglapi-mesa:i386 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libmount1:amd64 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), libmount1:i386 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), python3-reportlab-accel:amd64 (3.4.0-3build1, 3.4.0-3ubuntu0.1), sudo:amd64 (1.8.21p2-3ubuntu1.1, 1.8.21p2-3ubuntu1.2), libqt5dbus5:amd64 (5.9.5+dfsg-0ubuntu2.4, 5.9.5+dfsg-0ubuntu2.5), google-chrome-stable:amd64 (79.0.3945.130-1, 80.0.3987.87-1), libqt5sql5-sqlite:amd64 (5.9.5+dfsg-0ubuntu2.4, 5.9.5+dfsg-0ubuntu2.5), python3-pil:amd64 (5.1.0-1, 5.1.0-1ubuntu0.2), util-linux:amd64 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), libxatracker2:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libqt5widgets5:amd64 (5.9.5+dfsg-0ubuntu2.4, 5.9.5+dfsg-0ubuntu2.5), udev:amd64 (237-3ubuntu10.33, 237-3ubuntu10.38), libegl1-mesa:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libudev1:amd64 (237-3ubuntu10.33, 237-3ubuntu10.38), libudev1:i386 (237-3ubuntu10.33, 237-3ubuntu10.38), libqt5xml5:amd64 (5.9.5+dfsg-0ubuntu2.4, 5.9.5+dfsg-0ubuntu2.5), libgbm1:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), python3-renderpm:amd64 (3.4.0-3build1, 3.4.0-3ubuntu0.1), mount:amd64 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), libwayland-client0:amd64 (1.16.0-1ubuntu1.1~18.04.1, 1.16.0-1ubuntu1.1~18.04.3), libdrm-amdgpu1:amd64 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), libdrm-amdgpu1:i386 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), libblkid1:amd64 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), libblkid1:i386 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), libqt5gui5:amd64 (5.9.5+dfsg-0ubuntu2.4, 5.9.5+dfsg-0ubuntu2.5), libudev-dev:amd64 (237-3ubuntu10.33, 237-3ubuntu10.38), libnss-myhostname:amd64 (237-3ubuntu10.33, 237-3ubuntu10.38), systemd-sysv:amd64 (237-3ubuntu10.33, 237-3ubuntu10.38), libuuid1:amd64 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), libuuid1:i386 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), chromium-codecs-ffmpeg-extra:amd64 (79.0.3945.79-0ubuntu0.18.04.1, 79.0.3945.130-0ubuntu0.18.04.1), libwayland-egl1-mesa:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libpam-systemd:amd64 (237-3ubuntu10.33, 237-3ubuntu10.38), libdrm2:amd64 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), libdrm2:i386 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), systemd:amd64 (237-3ubuntu10.33, 237-3ubuntu10.38), libsmartcols1:amd64 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), libqt5core5a:amd64 (5.9.5+dfsg-0ubuntu2.4, 5.9.5+dfsg-0ubuntu2.5), rfkill:amd64 (2.31.1-0.4ubuntu3.4, 2.31.1-0.4ubuntu3.5), libgl1-mesa-dri:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libgl1-mesa-dri:i386 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libnss-systemd:amd64 (237-3ubuntu10.33, 237-3ubuntu10.38), bsdutils:amd64 (1:2.31.1-0.4ubuntu3.4, 1:2.31.1-0.4ubuntu3.5), bluez-obexd:amd64 (5.48-0ubuntu3.2, 5.48-0ubuntu3.3), libgl1-mesa-glx:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libgl1-mesa-glx:i386 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libxml2:amd64 (2.9.4+dfsg1-6.1ubuntu1.2, 2.9.4+dfsg1-6.1ubuntu1.3), libdrm-intel1:amd64 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), libdrm-intel1:i386 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), libdrm-radeon1:amd64 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), libdrm-radeon1:i386 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), mesa-vdpau-drivers:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), mesa-vdpau-drivers:i386 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libqt5network5:amd64 (5.9.5+dfsg-0ubuntu2.4, 5.9.5+dfsg-0ubuntu2.5), libbluetooth3:amd64 (5.48-0ubuntu3.2, 5.48-0ubuntu3.3), python3-reportlab:amd64 (3.4.0-3build1, 3.4.0-3ubuntu0.1), libexiv2-14:amd64 (0.25-3.1ubuntu0.18.04.4, 0.25-3.1ubuntu0.18.04.5), libwayland-server0:amd64 (1.16.0-1ubuntu1.1~18.04.1, 1.16.0-1ubuntu1.1~18.04.3), libqt5sql5:amd64 (5.9.5+dfsg-0ubuntu2.4, 5.9.5+dfsg-0ubuntu2.5), mesa-va-drivers:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), base-files:amd64 (10.1ubuntu2.7, 10.1ubuntu2.8), libglx-mesa0:amd64 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libglx-mesa0:i386 (19.2.1-1ubuntu1~18.04.1, 19.2.8-0ubuntu0~18.04.2), libdrm-common:amd64 (2.4.99-1ubuntu1~18.04.1, 2.4.99-1ubuntu1~18.04.2), libwayland-cursor0:amd64 (1.16.0-1ubuntu1.1~18.04.1, 1.16.0-1ubuntu1.1~18.04.3)
End-Date: 2020-02-10  14:10:25
 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now