Jump to content

Game crashes when new game is created

  • Branch: Live Branch Version: Windows Pending

I just downloaded the game on my Dell G3 3500 laptop and was excited to start playing. I go to start my very first game so I select the starter world, I'm greeted by the "world is generating" loading screen, everything is looking/loading great so far, the bar completes and then it goes black for a second in the top right hand of the screen and then a second larger black frame pops up over the entire screen and then it sends me back to the main menu with no trace of ever having tried to start a game, I try this method again but changing around the difficulty and the world but to no avail. I then proceeded with all the troubleshooting steps like verifying the files integrity (which it said was complete), lowering resolution/screen size, unistalling/reinstalling the game, changing around the firewall security etc. Nothing has worked, so here I am. I hope this is descriptive enough as I'm not too familiar with computers and this is about the extent of what I know how to do. Thank you and I hope you have a great New Year!

Steps to Reproduce

1. Load game

2. Select start new world

3. Pick world/wait for world to load

4. Game crash back to start screen

User Feedback

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...