Jump to content

Carbon skimmer not pumping until the game restarts

  • Branch: Live Branch Version: Windows Pending

I wanted to install a new carbon skimmer in the basement, but I couldn't get it to work... I've tried for like 1.5 hours when I broke, and ragequitted yelling "this broken, bugged piece of ****, why doesn't it work". As it turned out I installed the system just right because after I reloaded the game it started working like a dream. Before that it has no errors, the only status was "not pumping". I rotated every pipe, redesigned the whole system like 20 times, (and one time it pumped liquids to the next liquid bridge (3 block away). I rebuilt the skimmer itself at least 5 times, didn't solve the problem. As I said the only solution was to restart the game. 
It might help you to point out that originally the skimmer was standing in a shallow water (I had a minor incident a few floors above) could it affect it? The game was running for like 3-4 hours continously before this happened. 

Steps to Reproduce
Everything is in the description, I have no idea how to reproduce. I'm a dev too, I know it's not much, but it seems like something somewhere got into an invalid state (something that you don't include into the save file because reloading fixed it.) Do you pool the "moving liquid items" (no idea how you designate it) ? Maybe it run out of limits?

User Feedback

Had the same problem with the same solution. I don't recall if there was liquid where I built the skimmer, but it's possible.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...