Xbox One controller not working


DrTrill
  • Version: PC/MAC/Linux Pending

Summary

As the title suggests, D'ont Starve is not detecting the Xbox One controller, in fact it's detecting it as a generic controller not only that also the controls are so messed up, for instance pushing the start button triggers the up button, the controls are laggy, sometimes the game is triggering right joystick for itself.

More Infos

It's worth mentioning also that

  • I tried with checking and unchecking Xbox Configuration Support option in Steam and problem still occurs.
  • I tried with changing Gamepad template in Steam From Don't Starve Official template to the Standard Gamepad template and vice versa with no effect.
  • I uninstalled Steam, Don't Starve and all it's files content  and configurations and I tested with a fresh installation without messing with Steam configurations but the problem stil occurs.
  • Don't Starve Together is working perfectly fine.
  • My Mac is detecting the controller as (Xbox Wireless Controller).
  • This is really frustrating because I purchased the controller especially to play Don't Starve :(

Environnement

Controller                      Xbox One Controller Model 1708 (Prior 2016 model with Bluetooth integrated) to be exact (WL3-00106 Grey/Blue model)
System                          MacBook Pro (Early 2015 Model)
OS                                 MacOS Mojave 10.14.2
CPU                               2,7 GHz Intel Core i5
Memory                         16 Go 1867 MHz DDR3
GPU                               Intel Iris Graphics 6100 1536 Mo
Don't Starve Version      305507 With Reign of Giants and Shipwrecked DLCs installed with no mods and with no Steam lunch options

Info.plist

settings.ini

log.txt


Steps to Reproduce
1. Connect Xbox One controller in wireless mode 2. Lunch Steam 3. Lunch Don't Starve

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

Oh And I just noticed something right now, The game is detecting 2 Generic Gamepads in the controls options (I only have one controller connected to my mac)

And if I Disable the first Generic Gamepad the controller woks, But it still recognised it as a generic one (it show Button 0 etc...) in game.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now