Jump to content

Unable to open a curio chest from the the treasury

  • Pending

I got the complete Victorian chest from the klei live-stream giveaway and I received it but it's doesn't show up in the treasury for me to be able to opened.

Over here it says I received it in the recent discoveries but the treasury is completely empty.

Although I've supposedly received it and appears in my steam inventory, transaction on the klei site and in-game
it wouldn't appear in my treasury to get opened.

Steps to Reproduce

1. redeem a chest code on the klei site
2. log into the game
3. Now, it shows in recent discoveries & steam inventory but isn't in the treasury to be opened.

User Feedback


So the twitch streamer accidentally gave me a code from an old email that wasn't working. I was given a new code that immediately worked to redeem all the items in the Decorator's Chest.

I hope this helps the other two who posted here.

Edited by melonzie

Share this comment

Link to comment
Share on other sites

@melonzie, the problem we have in question it's that we've redeemed the codes, it worked but then when you enter the game and look through your treasury the chest isn't there for you to open despite it appearing in the steam inventory, game's recent discoveries, and the klei transaction history.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...