Jump to content

Steam Deck "Server Not Responding" Error on Linux runtime

  • Pending


My dad and I play DST and we encountered a bug where after leaving the caves the server would try to connect fore a long period of time and then give the "Server Not Responding" error. I have tried removing all the mods on both my windows 11 computer and the deck, but it hasn't helped. The only solution I've seen thus far is to not play on Linux Runtime. However, I would like to play with keyboard and mouse on the deck as well. I will put the caves and server log errors here so hopefully we can solve this issue once and for all. I personally have tried this on other servers and computers and the issue was solved there, but if I start a game on my PC then it will trigger the error. This error only occurs on the deck's side and not on the PC. I may have reason to suspect that it might be an issue with my computer, if there is any way I can reset my DST game without losing my skins, that would be amazing. Granted, this might not be the issue because I have tried to reset the game to no avail, but I ask because I think you might know a different way. If there is any more information I can provide, PLEASE TELL ME! 



Cyber Skink

server_log.txt server_log.txt

server.ini server.ini cluster.ini



caves_server_log.txt master_server_log.txt

Steps to Reproduce

Open DST and create a server on my computer and then join with steam deck. Once joined, go in and out of the caves and watch the crash.

User Feedback

There are no comments to display.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...