Jump to content

Launch DST fail

  • Pending

Hi guys,

I can't open DST for two days, I am using Mac and play it on Steam,

I tried "Verify Integrity of Game Files", not working, 

I tried unsubscribe all the Mod, not working, 

I tried reinstall DST, not working

I tried "steam://flushconfig" thing,  not working

Can anyone have a look of my client_log.txt? Any help will be appreciated!

Here are some of the code in , see the full file in attachment thanks!

[00:00:01]: [string "scripts/mainfunctions.lua"]:643: variable 'TheMixer' is not declared
LUA ERROR stack traceback:
        =[C] in function 'error'
        scripts/mainfunctions.lua(643,1) in function 'SetPause'
        =[C] in function 'GetPersistentString'
        scripts/playerprofile.lua(943,1) in function 'Load'
        scripts/main.lua(154,1) in main chunk
[00:00:02]:   taskgrouplist:    default    Together    
[00:00:02]:   taskgrouplist:    classic    Classic    
[00:00:02]:   taskgrouplist:    cave_default    Underground    
[00:00:02]:   taskgrouplist:    lavaarena_taskset    The Forge    
[00:00:02]:   taskgrouplist:    quagmire_taskset    The Gorge    
[00:00:02]: running main.lua
[00:00:02]: Could not load modindex    
[00:00:02]: File str is [return {disable_special_event_warning=false,known_api_version=10,known_mods={}}]    
[00:00:02]: DoLuaFile Error: (null)
[00:00:02]: LuaError but no error string
[00:00:02]: Error loading main.lua
[00:00:02]: Failed mSimulation->Reset()
[00:00:02]: Error during game initialization!
[00:00:02]: ModWorkshop::CancelDownloads clearing all unfinished downloads
[00:00:02]: Collecting garbage...
[00:00:02]: lua_gc took 0.03 seconds
[00:00:02]: ~ShardLuaProxy()
[00:00:02]: ~cEventLeaderboardProxy()
[00:00:02]: ~ItemServerLuaProxy()
[00:00:02]: ~InventoryLuaProxy()
[00:00:02]: ~NetworkLuaProxy()
[00:00:02]: ~SimLuaProxy()
[00:00:02]: ModWorkshop::CancelDownloads clearing all unfinished downloads
[00:00:02]: lua_close took 0.02 seconds
[00:00:02]: ModWorkshop::CancelDownloads clearing all unfinished downloads
[00:00:02]: Orphaned unnamed resource. This resource must have used Add( resource ) to insert itself into the manager. 
[00:00:02]: CurlRequestManager::ClientThread::Main() complete
[00:00:02]: HttpClient2 discarded 0 callbacks.
[00:00:02]: Shutting down


Steps to Reproduce


User Feedback

I fixed it....

I go to the DST.app, remove the folder called cached_mods then I can open the DST

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...