Jump to content

Dedicated Server works well but not show up on lan filter

Muhammed Adem E
  • Pending

Hi, I have an issue about dedicated servers. I searched about 2 days in forum also other discussion sites and cant solve this problem. At the end I started a fresh dedicated server by following instructions at the forum without any mods and caves, also default game settings (in case of any non-default options that causes problem). Server started successfully when I search by name at "browse games" screen, I can find it and connect successfully but not show up when lan filter is on. c_connect(...) command works fine with my local ip. Also another problem is ping shown as "???" I tried to solve this too but failed. I see a searching behaviour when I refresh at lan page. If my server is off refresh button available after about 1 second. When I started the server it takes about 3-5 seconds and nothing appears.

Solutions already tried :

1) run as administrator: steam.exe, dontstarve_steam.exe(64bit too), dontstarve_dedicated_server_nullrenderer.exe(64bit too)

2) Port forwarded to 10999 via modem interface (When I start the server, can see it on my router interface in the tab UPnP)

3) used different cluster tokens, from klei account page and console command.

4) run dedicated server from steamcmd and steam library interface 

5) changed local ip

6) disabled antivirus program and firewall

7) connected via mobile hotspot (to check if my modem causes the problem)

I don't have any problem with the gameplay but these little things are annoying. I couldn't fix them and just want to report. 


dst dedi prob.png

Steps to Reproduce

Started a dedicated server.

Can't see it when the lan filter on. 

can see it on all servers list but ping is "???"

User Feedback

Yes,  LAN mode can be configured in settings.ini by adding this line under the [account] heading:

dedicated_lan_server = true

Share this comment

Link to comment
Share on other sites

There is no settings.ini file by default. I created a new one at Documents\Klei\DoNotStarveTogether and put that line but it didn't work. Tried for cluster folders same result. Also tried for client.ini, cluster.ini and server.ini files under [account] but didn't work either.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...