Sign in to follow this  

'Apply' button not working on controller (xbox controller on pc)


icecradle
  • Pending

I am using an xbox one controller on PC. The 'apply' button (start button, or menu button on the one controller) is not functional/mapped. Clicking it does not work.

I was initially playing the game with controller (it detected the controller when I first loaded the game and asked if I wanted to use it and I clicked yes) and managed to get around the button not working by clicking to join a server with the mouse or letting the server host click the start button. When trying to create my own server, this was not working. I thought maybe I could create the server using keyboard and mouse, then switch back to controller, so I went into settings and changed the input to keyboard and mouse. Once I had finished setting up the server, I went back into settings to revert to controller and realised my huge error.

The apply button is required to change back to controller. And it's not functional. So now I can't change back to controller at all.

I tried remapping. I tried uninstalling and reinstalling the game to see if it would default me to controller, but this did not work and I'm stuck on keyboard controls now.

 

Things I have tried:

- remapping the 'start' button to something else. It seems to register the remap, as the start icon next to 'apply' is changed to whatever I select, however when I click to apply, nothing happens.

- uninstalling and reinstalling. the game loads up defaulted to keyboard controls and I cannot change this.

I don't have a 360 or other generic controller so I don't know if this is solely an issue with the xbox one controller.

 

Not sure it's relevant, but the xbox one controller, including the start/menu button, works fine with Don't Starve, the solo game.


Steps to Reproduce

Start the game with an xbox one controller
Go to Options> Settings, change Input Device to 'Xbox Controller'.
Try pressing the menu button to apply changes - nothing happens.

Go to Options>Controls
Scroll to find the binding for the start button (this is listed under 'pause') Rebind to something else (I tried right stick press).
The icon next to 'apply' changes to the right stick icon.
Press right stick - nothing happens.

Sign in to follow this  


User Feedback


There are no comments to display.



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now