Sign in to follow this  

64-bit client doesn't start (but 32-bit one does)


IceNine99
  • Pending

I've done the whole rigamarole; updating my OS and graphics driver, verifying game files, of course uninstalling DST and installing it again, including after unsubscribing from every mod and then clearing out my mods folder manually, and also reinstalling Steam itself.

The machine is a new Windows desktop. Detailed specs are in the DxDiag output file attached. Here's a preview from the Settings menu.

Processor          AMD Ryzen 5 3600 6-Core Processor                 3.59 GHz
Installed RAM    16.0 GB
System type      64-bit operating system, x64-based processor

To be more precise:

  • The little dialogue box pops up asking me to select what version of the client I want to start.
    • Selecting "Play Don't Starve Together (32 Bit)" launches a fully functional client which is a usable workaround for me.
    • Selecting "Play Don't Starve Together" changes Steam's CANCEL button into a STOP button for about two seconds, after which it reverts to a PLAY button, with no visible effect. No client log is created.

I installed DST on this machine (the first time, anyway) before the QOL update. Behaviour has not changed since.

I don't seem to have a mini-dump file in the bin folder.

(Following is some info that probably isn't relevant, but I thought I'd post just in case.)

Spoiler

For fun, I slid into the bin and bin64 folders in my DST installation, and tried launching the exes therein myself. Double-clicking bin/dontstarve_steam.exe has the same effect as described (including briefly changing the PLAY button in my Steam window). bin64/dontstarve_steam_x64.exe gives me a fun sequence of error dialogues saying "The code execution cannot proceed because [a dll] was not found. Reinstalling the program may fix this problem.", where [a dll] is either VCRUNTIME140.dll or MSVCP140.dll. (Doing a quick search in my Steam folder has located files with matching names in Steam/bin/cef/cef.win7x64 and cef.win7.)

Oh by the way, I run a dedicated server using this installation (because I use a few mods I don't quite want to publish yet, and I don't know how to add them to a server running using the steamcmd installation).
As such, I've run a batch file that launches bin64/dontstarve_dedicated_server_nullrenderer_x64.exe – and it works fine, whether I'm connecting from a 32-bit client on the same machine or a 64-bit client from my laptop.

My machine is also loaded with a Linux installation, and I've installed Steam and DST on the other partition. 64-bit client runs normally in Linux.

Anyone got anything?


Steps to Reproduce

> Be me
> Launch 64-bit DST client from Steam

Sign in to follow this  


User Feedback


There are no comments to display.



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now