Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

AnSnarkista

Can't Run Motn 64 Bits Archlinux

4 posts in this topic

Hi! First of all, thanks a lot for this awesome game, I think it is great, and to the devs for porting it to Linux.

 

I'm trying to run it in 64 bits mode, but I got a problem (I changed the permises of course), when I run it by terminal, (./ninja-bin or ./ninja-bin64), it says:

ERROR: Missing required OpenGL extensions.ERROR: Missing required OpenGL extensions.ERROR: Missing required OpenGL extensions.ERROR: Missing required OpenGL extensions.Violación de segmento (`core' generado)

If I open the 32bits, it works properly.

 

Is there any difference between the two architectures? If it's better the 64bits version, what extensions do I need?

 

I have an ArchLinux x86_64, so I can run it in 64bits mode.

 

 

Thanks a lot!!
 

Share this post


Link to post
Share on other sites

See the discussion over at the Arch Linux forum starting with this post, where someone had the same problem and we narrowed it down to the fact that the game requires S3TC support, which the open-source Linux graphics drivers don't provide by default. See that discussion thread for further instructions how to fix it.

 

As for why the 32bit version already worked for you, my guess would be that you already have the lib32-libtxc_dxtn package installed (because some other game you installed in the past required it as a dependency), but didn't have the corresponding 64bit package libtxc_dxtn installed yet.

Share this post


Link to post
Share on other sites

Long story short, this problem can be fixed by setting the environment variable force_s3tc_enable=true before starting the game.

 

This will cause the open-source Linux graphics drivers to enable their S3TC texture decompression support, which is needed by the game.

 

The closed-source graphics drivers (ATI Catalyst and NVIDIA) don't need this variable (their S3TC support is always enabled), but it doesn't hurt them either (they'll simply ignore it). Thus I think it would make sense for the developers to simply set the variable in the ninja-bin launch script, by adding this line near the top:

export force_s3tc_enable=true

----

PS: Another way for users to fix this problem is to install the txc_dxtn library (the exact package name depends on the distribution). It provides full S3TC texture loading and saving support (whereas the built-in force_s3tc_enable only provides partial loading and no saving support, but it's enough for this game).

The problem is that the txc_dxtn library is patent-encumbered (i.e. in some countries it might not technically be legal to use it without permission from the patent holders). Thus the force_s3tc_enable variable is a better solution.

1 person likes this

Share this post


Link to post
Share on other sites

Long story short, this problem can be fixed by setting the environment variable force_s3tc_enable=true before starting the game.

 

This will cause the open-source Linux graphics drivers to enable their S3TC texture decompression support, which is needed by the game.

 

The closed-source graphics drivers (ATI Catalyst and NVIDIA) don't need this variable (their S3TC support is always enabled), but it doesn't hurt them either (they'll simply ignore it). Thus I think it would make sense for the developers to simply set the variable in the ninja-bin launch script, by adding this line near the top:

export force_s3tc_enable=true

----

PS: Another way for users to fix this problem is to install the txc_dxtn library (the exact package name depends on the distribution). It provides full S3TC texture loading and saving support (whereas the built-in force_s3tc_enable only provides partial loading and no saving support, but it's enough for this game).

The problem is that the txc_dxtn library is patent-encumbered (i.e. in some countries it might not technically be legal to use it without permission from the patent holders). Thus the force_s3tc_enable variable is a better solution.

Hi thanks, worked prefectly for me. (Linux Ubuntu 64Bit 12.04 (Intel Messa))

Share this post


Link to post
Share on other sites