Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

TotalTrashDream

Both Master and Caves Wont Run at the Same Time

Recommended Posts

so i used this guide to make a dedicated server

and everything was working fine, but the only problem is that both servers (master and caves) wont run at the same time

if i launch the master first then the caves, the caves wont run

if i launch the caves first then the master, the master wont run

the one not running will end with this:

hm.PNG.1df82f603905aadcd13a4a674abb614c.PNG

someone please help!

Share this post


Link to post
Share on other sites
Zillvr    1,503

Hey @TotalTrashDream, just based on the server log screenshot you posted, I presume it's due to both the caves and master's server.ini settings files both use the same server_port number. So double check your files and see whether they're the same, if they are change the either one of them to 10998 or something and there shouldn't be any more [errors] that says "SOCKET_PORT_ALREADY_IN_USE".

So after changing the server_port for the Caves to 10998, while Master's server_port is 10999, try and start up your servers again.

Notify me through a quote if it works or not. Cheers.

Share this post


Link to post
Share on other sites
On 1/12/2018 at 6:30 PM, Zillvr said:

Hey @TotalTrashDream, just based on the server log screenshot you posted, I presume it's due to both the caves and master's server.ini settings files both use the same server_port number. So double check your files and see whether they're the same, if they are change the either one of them to 10998 or something and there shouldn't be any more [errors] that says "SOCKET_PORT_ALREADY_IN_USE".

So after changing the server_port for the Caves to 10998, while Master's server_port is 10999, try and start up your servers again.

Notify me through a quote if it works or not. Cheers.

it sort of worked, both servers were up and running

the only problem was that the servers were both separate servers

one for the overworld, and one for the caves

they weren't connected at all

Share this post


Link to post
Share on other sites
Zillvr    1,503

@TotalTrashDream if you're sure all your files are in the correct locations.

Spoiler

UpdatedDedicatedFolder.png.e24bf25c06be9f484c883ac1efcbcfde.png

Then I think the issue is in the server.ini of the Caves folder. Open it and the setting for the following should be like this:

is_master = false

While for the Master folder's server.ini should have the opposite:

is_master = true

 

Share this post


Link to post
Share on other sites
8 hours ago, Zillvr said:

@TotalTrashDream if you're sure all your files are in the correct locations.

  Hide contents

UpdatedDedicatedFolder.png.e24bf25c06be9f484c883ac1efcbcfde.png

Then I think the issue is in the server.ini of the Caves folder. Open it and the setting for the following should be like this:


is_master = false

While for the Master folder's server.ini should have the opposite:


is_master = true

 

its working fine now! thank you alot, @Zillvr!

Share this post


Link to post
Share on other sites