DejaVuZXY

  • Content Count

    24
  • Joined

  • Last visited

Community Reputation

9 Neutral

About DejaVuZXY

  • Rank
    Junior Member
...

Badges

Recent Profile Visitors

701 profile views
  1. I decided to put all my DST servers offline until Klei can realise why they are a pretty bad development team and try to pull their act together. I don't mean to flame or be harsh, but simply speak the truth here. The game is wonderful and it could potentially be a good game but unfortunately the entire development team MUST change. Also please don't hide behind "it's an alpha/beta/gamma early access, whatever version" that is only an excuse for incompetent developers to hide behind. Good software can be developed even in early stages if proper knowledge and then testing goes into it. There is no good documentation for the changes being made on different updates. Pretty much every single update they release nearly ALWAYS breaks something in some way, may it be mods, new bugs in game or the game itself gets broken. There is no 1 place to get all the information you need about the game and on how to set up the servers for it or tweak settings etc. Even wikia gave up and simply directed people to Klei forums because it's all a huge mess. I have been with the games development progress for a long time and it only gets worse over time. Who the hell releases an updates before a weekend? So that the game gets broken, people can't enjoy it during their free days and developers are away? The only reason this game is still alive is because of modding support and modders in general who have come together and fix massive performance problems etc, some of these mods were written in a day (that help to reduce performance problems a lot). Why couldn't Klei do it in all those months? I have some free time at the end of this month and I am willing to teach and guide Klei's development team on how to improve the development process because otherwise this is going to be another game that has huge potential, but bites the dust because of developers lack of knowledge about workflow.
  2. "Don't touch something that already works." This completely broke my 1800 days running server saves. I somehow managed to restore the world, but not player saves. Anyway can you guys please give FULL list of parameters and information on what of said parameters can be put inside server.ini, client.ini and cluster.ini, since you decided to change and remove and rearrange some/most of them into many different config files (because reasons), i have no clue what does what anymore and what can be where exactly. Also provide EXAMPLE VALUES on said parameters as well. Good job guys, you've done it yet again!
  3. I confirm this. Muche crafted some awesome scripts and eventually found out the bug. When the server first starts up it's fine and no errors show in the log file. When the server keeps running for longer period of time, few hours or so, the error log is spammed and filled with these lines: [15:38:32]: Error serializing lua state for entity evergreen[115605] [15:38:32]: Net array has 68 elements; exceeds maximum size of 31 [15:38:32]: Error serializing lua state for entity evergreen[115335] [15:38:32]: Net array has 67 elements; exceeds maximum size of 31 [15:38:32]: Error serializing lua state for entity evergreen[116092] [15:38:34]: Net array has 68 elements; exceeds maximum size of 31 [15:38:34]: Error serializing lua state for entity evergreen[113608] [15:38:35]: Net array has 68 elements; exceeds maximum size of 31 [15:38:35]: Error serializing lua state for entity deciduoustree[107169] [15:38:36]: Net array has 62 elements; exceeds maximum size of 31 The longer the server runs, the more spam the error log receives. This is rather annoying bug.
  4. Please ignore this Thread. The issue lied somewhere else and was a funny combination of coincidences that made me think this was a game bug. This bug comes up when you have the mod "Structures and more" enabled in the server during cave world generation.
  5. It seems the Labyrinth biome in Caves (Near Ancient Guardian) is not generating correctly anymore. I don't have screenshots, but basically the Spider Dropper webs are generated outside the labyrinth ground including with certain Clockwork monsters and broken relic prefabs. They all float in the air and are not accessible by the player. Some of the said prefabs are generated correctly as well, but mostly stuff is simply floating in the air. This is the server Map Generation log part, it has some weird entries: http://pastebin.com/UuVLYW4V I don't know when this bug arose but i remember the Caves Labyrinth was ok at some point and without those issues. Recently wanted to generate a new map and noticed those issues. I tried to generate multiple maps, the problem was there every time with similar log entries.
  6. It seems the Labyrinth biome in Caves (Near Ancient Guardian) is not generating correctly anymore. I don't have screenshots, but basically the Spider Dropper webs are generated outside the labyrinth ground including with certain Clockwork monsters and broken relic prefabs. They all float in the air and are not accessible by the player. Some of the said prefabs are generated correctly as well, but mostly stuff is simply floating in the air. This is the server Map Generation log part, it has some weird entries: http://pastebin.com/UuVLYW4V I don't know when this bug arose but i remember the Caves Labyrinth was ok at some point and without those issues. Recently wanted to generate a new map and noticed those issues. I tried to generate multiple maps, the problem was there every time with similar log entries. View full bug
  7. Hmm, the next issue is mod related... and to get them in a working order... Anyway yesterday we were talking to another modder and he ended up pushing another update to his mod, then this happened (mod is "Fix Multiplayer"): (This is dedicated server error log) Failure error code received: 404 [00:00:17]: With Body: <HTML><HEAD><TITLE>Error</TITLE></HEAD><BODY> An error occurred while processing your request.<p> Reference #25.4e2c8343.1448433918.1c8ccb93 </BODY></HTML> Remember this guys? I think it's back again! So yes, i can't download his mod and any new mods that were published to workshop as of yesterday and perhaps maybe even day before that. All the other mods that have not received an update are downloading fine. Clientside error log is this when trying to download a mod which you have subscribed to: [00:00:28]: DownloadPublishedFileV2() [00:00:28]: Did not find the ugc handle in the cache. This is likely because you're subscribed to a non-existent file 503889043 [00:00:28]: DownloadPublishedFileV2() [00:00:28]: OnDownloadPublishedFileResultV2 [00:00:28]: EResult 2, 400055014014527857 [00:00:28]: Failed downloading mod! [00:00:35]: EResult 15, 503889043 [00:00:35]: Failed getting mod details. If you just want to talk to me then you don't have to go these lengths to get me report bugs...
  8. Thanks for responding and for the clarification. I understand what you mean by the world being coherent, but as there are different game mods, i believe the games "philosophy" changes as well when new gamemod is played. I can't play on any other game mod than Wilderness as in those, people nearly always die and mapwipes are very often to happen, which means 80% of the game content can never be explored. The Wilderness i love but the issue with resources running out is a problem (in my head at least) as the late joiners have pretty much nothing to do in the game world anymore, it's hard to survive and half the game content has simply "depleted" from the world. That said, i do like the direction you are going with this game and you have all done a great job. Once the game mechanics and performance issues get sorted out and server clustering is tweaked (easier and more flexible configuration, portal connecting etc), i think the game has huge potential of becoming something really amazing. Again, good job!
  9. With help i got my mods code sorted out. I don't know which version of the code you saw before, the broken one or now the fixed one, anyway it's working. (a bit off-topic but...) While i got a shard of your attention here (perhaps people will see what i just did there) i would also like to know if you're adding more options to worldgenoverride to be able to make other prfeabs renewable as well? Currently a LOT of things like Ancient Guardian, different statues, clockwork monsters etc etc etc are not renewable and in Wilderness servers that becomes a huge issue. I have been using "Fix Multiplayer" mod for the resource renewal code and i love the method used there, unfortunately that part of the mod is not working very well and/or occasionally causes crashes. My dream would be to see a proper way to be able to make EVERY single prefab renewable. (and i can't stress that enough... every single one, the ones not needed for renewal can be configured not to then) That said, Wilderness servers start lagging eventually when certaint prefabs overrun the place, may they be monsters or items or whatever else. Which means there should be some method that would clean up items left on the ground after X (configurable value) amount of days, same goes for monsters, there should be an option to set a configurable limit to these. ALSO, there is a bug with monkey, i don't have the error log anymore, but basically i think it happens when they start turning into shadowmonkeys. Nevertheless, good job on the caves, absolutely love it.
  10. I would like to report a bigger problem we have found together with other modders. Currently many of the mods, that worked fine before the update, are causing server crashes. This is not happening because the mods might be conflicting with other mods, no it is a standalone problem with every mod that uses the "mysterious" function that causes this to happen. Let's go: Mod "Craft Loot Run" produces this kind of error http://pastebin.com/FzHXY7r3 as the mod implements a feature where items can drop when mining boulders, trees, buildings etc. I updated the mod, but left the faulty code commented in if any dev wants to take a look. The server crash happens when, for example a boulder is being mined and the code triggers by trying to drop custom loot, but can't because the item was mysteriously destroyed before it reached the "reality" Mod "Birds and Berries and Trees and Flowers for friends" produces simillar issue. Error http://pastebin.com/hiHXf7VZ . The mod implements, among other things, custom trees and pineapple bushes and the crash occures when you try to dig up the pineapple bush for example. There are other mods as well most likely, but i haven't had the time to grab error logs from these, but the crash works similarly. Is a function changed radically in a code somewhere on Klei side or what exactly is going on because a lot of modders are puzzled over this issue. Thanks in advance! (and thanks for the Caves, hopefully the bugs can be ironed out and people can actually play for a little while without being stuck forever on 1 gameday as of the crashes all the time)