Winsyrstrife

  • Content count

    26
  • Joined

  • Last visited

Community Reputation

6 Neutral

About Winsyrstrife

  • Rank
    Junior Member

Badges

Don't Starve Together
  • Contributor
Oxygen Not Included
  • Alpha Contributor
  1. That's the thing. I haven't changed anything on the networking side, other than recreating the forwarding rules. Looking through the logs and the iptables rules, I see the POSTROUTING chain is already set to loopback LAN connections, so I think my real problem was a mis-configuration in the settings.ini file (perhaps server pause when empty on initial world creation). If you're using Tomato firmware in your router, NAT Loopback is in: Advanced > Firewall, NAT section, NAT Loopback The choices are All, Forwarded Only, Disabled. Default is "Forwarded Only", which should already be working if your ports have been forwarded to the appropriate LAN client. You can leave NAT target as "Masquerade". There should be something similar in all modern routers, though the wording for its implementation may be different.
  2. I had begun wondering about this myself. My server instances have been problematic (not listed in server browser) when alternate ports are used. I'm using an ASUS RT-N56U, Tomato firmware (Shibby's mod). I couldn't really put a rhyme to the reason in why alternate ports wouldn't work (10997,10998). I've disabled every security layer aside from the edge router. As a test, I connected to my cousin's wifi (separate network), and set up forwarding using the alternate port. Worked fine....So, connected back to my N56U network, wiped the port 10998 forwarding rule, re-created it, tested server instance using port 10998. Boom, works. This is a behavior I've never seen in my router, but hey, every day is a new day, new possibilities... I'll be creating several new instances for testing / digging through the IP logs, to get a better handle on things.