mikey99222

  • Content count

    62
  • Joined

  • Last visited

 Content Type 

Profiles

Forums

Downloads

Klei Bug Tracker

Game Updates

Hot Lava Bug Reporter

Everything posted by mikey99222

  1. hello. i am new to DST modding and tried to make a character but got a vast majority of errors, after looking in log.txt 9000( or over ) times i got an error i could not fix, any help appreciated. pleeeeease don't use the art, i do not see why you would want to as it is bucket tool on paint.net over wilsons art but whatever. log.txt Michaelh.zip
  2. i have attached the log file, but i keep getting an error, mainly Orphaned unnamed resource. This resource must have used Add( resource ) to insert itself into the manager. repeatedly, any ideas, help much appreciated! log.txt
  3. HELP! CUSTOM ITEM NOT WORKING

    i have another broken mod (http://forums.kleientertainment.com/topic/50008-help-dont-starve-together-character-mod-help-needed/) but i think i will try to fix, then i will learn, then i can help others too!
  4. HELP! CUSTOM ITEM NOT WORKING

    Remove these two assets from your wand.lua and remove the recipe from wand.lua as well. It will work. Now you should be able to alter the wand.tex and wand.xml to your desires. thank you sooooo much, it works, (it is invisible when held but hey!) *i think i can fix this, i will add ALL assets from wand.lua to the modmain.lua*
  5. HELP! CUSTOM ITEM NOT WORKING

    This means that you're .tex file is inaccurately sized or your .xml is not pointing to the proper region where the image is located. Use the zip file I provided to create an exact replica for placement of your item. Once that is completed copy the .xml I provided and change the name inside of it to suit your .tex file and remember to rename your .xml file to the same as your .tex file. If you create an exact replica you should have it working. I made a replica... in the region, however even after renaming it all and the dug_reeds in the atlas, it did not work... log.txt michaelwand.zip
  6. HELP! CUSTOM ITEM NOT WORKING

    This indicates that your region area in your wand.tex and wand.xml file are not correct. You should recreate the wand.tex and wand.xml file and make it look like the following if you want it for inventory item. inventoryimages.zip still broken, shows this if it is any help log.txt michaelwand.zip after i uploaded this i recreated the TEX file, same error.
  7. HELP! CUSTOM ITEM NOT WORKING

    it did not work new uploads: michaelwand.zip log.txt log.txt
  8. HELP! CUSTOM ITEM NOT WORKING

    Into your prefab file instead of having it in the modmain.lua file. Also add this line to import the .tex file as an asset. This goes in your prefab file as well. Also add these lines to your prefab file under the inventoryitem component to see if it will help. After making these changes, test it again and see if it still displays issues. thank you, i shall try this
  9. HELP! CUSTOM ITEM NOT WORKING

    ok, here it is michaelwand.zip
  10. HELP! CUSTOM ITEM NOT WORKING

    I have fixed that, but i am having a new error any help? when i go to hover over the recipie, it crashes, i commented out the recipie and replaced with sticks, the light on the .WAR tab goes green. however, even c_give("wand") crashes my game. help? log.txt
  11. HELP! CUSTOM ITEM NOT WORKING

    thank you, i shall try this
  12. HELP! CUSTOM ITEM NOT WORKING

    my game still crashes though new log log.txt
  13. HELP! CUSTOM ITEM NOT WORKING

    ok, new problem (fixed other one but still fixing same mod) log.txt p.s ok i will use the edit button
  14. HELP! CUSTOM ITEM NOT WORKING

    here is the log for this mod (new problem) log.txt
  15. HELP! CUSTOM ITEM NOT WORKING

    sorry, that was my other mod. gets confusing
  16. HELP! CUSTOM ITEM NOT WORKING

    after this it just crashes, nothing under that in the log log.txt
  17. HELP! CUSTOM ITEM NOT WORKING

    [00:00:35]: Unload BE done [00:00:36]: Mod: Michael (MICHAEL) Registering prefabs [00:00:36]: Mod: Michael (MICHAEL) Registering prefab file: prefabs/michael [00:00:36]: Mod: Michael (MICHAEL) michael [00:00:36]: Mod: Michael (MICHAEL) Registering default mod prefab is the error i now get help?
  18. HELP! CUSTOM ITEM NOT WORKING

    i have this there 49:return Prefab("common/inventory/wand", fn, assets, prefabs)50:STRINGS.NAMES.WAND = "Michael's lightning sword"51:STRINGS.CHARACTERS.MICHAEL.DESCRIBE.WAND = "kinex, are you sure this is safe?"52:STRINGS.CHARACTERS.GENERIC.DESCRIBE.WAND= "Michael must be a genius!" Thank you for fast reply wand.lua
  19. [00:00:08]: Mod downloads complete. [00:00:08]: GetCachedUGCCount 0 [00:00:08]: SteamWorkshop::CompleteCallback (success, Mods were updated.) set [00:00:08]: SimLuaProxy::OnUpdateWorkshopModsComplete(ok., Mods were updated.) [00:00:08]: Reloading Mod Info Prefabs [00:00:08]: Loading Mod Info Prefabs [00:00:08]: Unloading Mod Info Prefabs [00:00:13]: Unloading Mod Info Prefabs [00:00:13]: Collecting garbage... [00:00:13]: lua_gc took 0.01 seconds [00:00:13]: ~NetworkLuaProxy() [00:00:13]: ~SimLuaProxy() [00:00:13]: lua_close took 0.01 seconds [00:00:13]: ReleaseAll [00:00:13]: ReleaseAll Finished [00:00:13]: cGame::StartPlaying [00:00:13]: LOADING LUA [00:00:13]: DoLuaFile scripts/main.lua [00:00:13]: DoLuaFile loading buffer scripts/main.lua [00:00:13]: scripts/main.lua(167,1) running main.lua [00:00:13]: loaded modindex [00:00:13]: ModIndex: Beginning normal load sequence. [00:00:13]: ModIndex:GetModsToLoad inserting moddir, Michael [00:00:13]: Could not load mod_config_data/modconfiguration_Michael [00:00:13]: Loading mod: Michael (MICHAEL) [00:00:13]: Mod: Michael (MICHAEL) Loading modworldgenmain.lua [00:00:13]: Mod: Michael (MICHAEL) Mod had no modworldgenmain.lua. Skipping. [00:00:13]: Mod: Michael (MICHAEL) Loading modmain.lua [00:00:13]: Mod: Michael (MICHAEL) Error loading mod! [string "../mods/Michael/modmain.lua"]:59: attempt to index global 'AddModCharacter' (a function value) LUA ERROR stack traceback: ../mods/Michael/modmain.lua(59,1) in main chunk =[C] in function 'xpcall' scripts/util.lua(455,1) in function 'RunInEnvironment' scripts/mods.lua(373,1) in function 'InitializeModMain' scripts/mods.lua(354,1) in function 'LoadMods' scripts/main.lua(244,1) in function 'ModSafeStartup' scripts/main.lua(292,1) =[C] in function 'SetPersistentString' scripts/mainfunctions.lua(24,1) in function 'SavePersistentString' scripts/modindex.lua(76,1) =[C] in function 'GetPersistentString' scripts/modindex.lua(63,1) in function 'BeginStartupSequence' scripts/main.lua(291,1) in function 'callback' scripts/modindex.lua(410,1) =[C] in function 'GetPersistentString' scripts/modindex.lua(390,1) in function 'Load' scripts/main.lua(290,1) in main chunk [00:00:13]: [string "../mods/Michael/modmain.lua"]:59: attempt to index global 'AddModCharacter' (a function value) LUA ERROR stack traceback: ../mods/Michael/modmain.lua(59,1) in main chunk =[C] in function 'xpcall' scripts/util.lua(455,1) in function 'RunInEnvironment' scripts/mods.lua(373,1) in function 'InitializeModMain' scripts/mods.lua(354,1) in function 'LoadMods' scripts/main.lua(244,1) in function 'ModSafeStartup' scripts/main.lua(292,1) =[C] in function 'SetPersistentString' scripts/mainfunctions.lua(24,1) in function 'SavePersistentString' scripts/modindex.lua(76,1) =[C] in function 'GetPersistentString' scripts/modindex.lua(63,1) in function 'BeginStartupSequence' scripts/main.lua(291,1) in function 'callback' scripts/modindex.lua(410,1) =[C] in function 'GetPersistentString' scripts/modindex.lua(390,1) in function 'Load' scripts/main.lua(290,1) in main chunk [00:00:13]: Error error! We tried displaying an error but TheFrontEnd isn't ready yet... [00:00:13]: LOADING LUA SUCCESS [00:00:13]: PlayerDeaths loaded morgue 1936 [00:00:13]: loaded profile [00:00:13]: bloom_enabled false [00:00:13]: loaded saveindex [00:00:13]: OnFilesLoaded() [00:00:13]: OnUpdatePurchaseStateComplete [00:00:13]: Unload BE [00:00:13]: Unload BE done [00:00:14]: Mod: Michael (MICHAEL) Registering prefabs [00:00:14]: Mod: Michael (MICHAEL) Registering prefab file: prefabs/michael [00:00:14]: error calling LoadPrefabFile in mod Michael (MICHAEL): [string "scripts/util.lua"]:292: Could not find an asset matching anim/Michael.zip in any of the search paths. LUA ERROR stack traceback: =[C] in function 'assert' scripts/util.lua(292,1) in function 'resolvefilepath' scripts/mainfunctions.lua(72,1) in function 'RegisterPrefabs' scripts/mainfunctions.lua(99,1) =(tail call) ? =[C] in function 'xpcall' scripts/mods.lua(165,1) scripts/mods.lua(460,1) in function 'RegisterPrefabs' scripts/gamelogic.lua(154,1) in function 'LoadAssets' scripts/gamelogic.lua(931,1) in function 'DoResetAction' scripts/gamelogic.lua(949,1) in function 'complete_callback' ... =[C] in function 'GetPersistentString' scripts/saveindex.lua(90,1) in function 'Load' scripts/gamelogic.lua(970,1) in function 'callback' scripts/playerprofile.lua(671,1) in function 'Set' scripts/playerprofile.lua(553,1) =[C] in function 'GetPersistentString' scripts/playerprofile.lua(551,1) in function 'Load' scripts/gamelogic.lua(969,1) in main chunk =[C] in function 'require' scripts/mainfunctions.lua(677,1) [00:00:14]: Disabling Michael (MICHAEL) because it had an error. [00:00:14]: Disabling Michael (MICHAEL) because it had an error. [00:00:14]: SCRIPT ERROR! Showing error screen [00:00:14]: Mod: Michael (MICHAEL) Registering default mod prefab [00:00:14]: ModIndex: Load sequence finished successfully. [00:00:14]: Reset() returning [00:00:14]: QueryServerComplete no callback [00:00:15]: QueryServerComplete no callback [00:00:16]: Force aborting... PLEASE HELP! I HAVE CHECKED THAT ANIM IS SPELLED CORRECTLY AND THAT michael.zip IS INSIDE IT, PLEASE HELP!!! michael.lua
  20. [Tutorial] Using Extended Sample Character Template

    [00:00:08]: Mod downloads complete. [00:00:08]: GetCachedUGCCount 0 [00:00:08]: SteamWorkshop::CompleteCallback (success, Mods were updated.) set [00:00:08]: SimLuaProxy::OnUpdateWorkshopModsComplete(ok., Mods were updated.) [00:00:08]: Reloading Mod Info Prefabs [00:00:08]: Loading Mod Info Prefabs [00:00:08]: Unloading Mod Info Prefabs [00:00:13]: Unloading Mod Info Prefabs [00:00:13]: Collecting garbage... [00:00:13]: lua_gc took 0.01 seconds [00:00:13]: ~NetworkLuaProxy() [00:00:13]: ~SimLuaProxy() [00:00:13]: lua_close took 0.01 seconds [00:00:13]: ReleaseAll [00:00:13]: ReleaseAll Finished [00:00:13]: cGame::StartPlaying [00:00:13]: LOADING LUA [00:00:13]: DoLuaFile scripts/main.lua [00:00:13]: DoLuaFile loading buffer scripts/main.lua [00:00:13]: scripts/main.lua(167,1) running main.lua [00:00:13]: loaded modindex [00:00:13]: ModIndex: Beginning normal load sequence. [00:00:13]: ModIndex:GetModsToLoad inserting moddir, Michael [00:00:13]: Could not load mod_config_data/modconfiguration_Michael [00:00:13]: Loading mod: Michael (MICHAEL) [00:00:13]: Mod: Michael (MICHAEL) Loading modworldgenmain.lua [00:00:13]: Mod: Michael (MICHAEL) Mod had no modworldgenmain.lua. Skipping. [00:00:13]: Mod: Michael (MICHAEL) Loading modmain.lua [00:00:13]: Mod: Michael (MICHAEL) Error loading mod! [string "../mods/Michael/modmain.lua"]:59: attempt to index global 'AddModCharacter' (a function value) LUA ERROR stack traceback: ../mods/Michael/modmain.lua(59,1) in main chunk =[C] in function 'xpcall' scripts/util.lua(455,1) in function 'RunInEnvironment' scripts/mods.lua(373,1) in function 'InitializeModMain' scripts/mods.lua(354,1) in function 'LoadMods' scripts/main.lua(244,1) in function 'ModSafeStartup' scripts/main.lua(292,1) =[C] in function 'SetPersistentString' scripts/mainfunctions.lua(24,1) in function 'SavePersistentString' scripts/modindex.lua(76,1) =[C] in function 'GetPersistentString' scripts/modindex.lua(63,1) in function 'BeginStartupSequence' scripts/main.lua(291,1) in function 'callback' scripts/modindex.lua(410,1) =[C] in function 'GetPersistentString' scripts/modindex.lua(390,1) in function 'Load' scripts/main.lua(290,1) in main chunk [00:00:13]: [string "../mods/Michael/modmain.lua"]:59: attempt to index global 'AddModCharacter' (a function value) LUA ERROR stack traceback: ../mods/Michael/modmain.lua(59,1) in main chunk =[C] in function 'xpcall' scripts/util.lua(455,1) in function 'RunInEnvironment' scripts/mods.lua(373,1) in function 'InitializeModMain' scripts/mods.lua(354,1) in function 'LoadMods' scripts/main.lua(244,1) in function 'ModSafeStartup' scripts/main.lua(292,1) =[C] in function 'SetPersistentString' scripts/mainfunctions.lua(24,1) in function 'SavePersistentString' scripts/modindex.lua(76,1) =[C] in function 'GetPersistentString' scripts/modindex.lua(63,1) in function 'BeginStartupSequence' scripts/main.lua(291,1) in function 'callback' scripts/modindex.lua(410,1) =[C] in function 'GetPersistentString' scripts/modindex.lua(390,1) in function 'Load' scripts/main.lua(290,1) in main chunk [00:00:13]: Error error! We tried displaying an error but TheFrontEnd isn't ready yet... [00:00:13]: LOADING LUA SUCCESS [00:00:13]: PlayerDeaths loaded morgue 1936 [00:00:13]: loaded profile [00:00:13]: bloom_enabled false [00:00:13]: loaded saveindex [00:00:13]: OnFilesLoaded() [00:00:13]: OnUpdatePurchaseStateComplete [00:00:13]: Unload BE [00:00:13]: Unload BE done [00:00:14]: Mod: Michael (MICHAEL) Registering prefabs [00:00:14]: Mod: Michael (MICHAEL) Registering prefab file: prefabs/michael [00:00:14]: error calling LoadPrefabFile in mod Michael (MICHAEL): [string "scripts/util.lua"]:292: Could not find an asset matching anim/Michael.zip in any of the search paths. LUA ERROR stack traceback: =[C] in function 'assert' scripts/util.lua(292,1) in function 'resolvefilepath' scripts/mainfunctions.lua(72,1) in function 'RegisterPrefabs' scripts/mainfunctions.lua(99,1) =(tail call) ? =[C] in function 'xpcall' scripts/mods.lua(165,1) scripts/mods.lua(460,1) in function 'RegisterPrefabs' scripts/gamelogic.lua(154,1) in function 'LoadAssets' scripts/gamelogic.lua(931,1) in function 'DoResetAction' scripts/gamelogic.lua(949,1) in function 'complete_callback' ... =[C] in function 'GetPersistentString' scripts/saveindex.lua(90,1) in function 'Load' scripts/gamelogic.lua(970,1) in function 'callback' scripts/playerprofile.lua(671,1) in function 'Set' scripts/playerprofile.lua(553,1) =[C] in function 'GetPersistentString' scripts/playerprofile.lua(551,1) in function 'Load' scripts/gamelogic.lua(969,1) in main chunk =[C] in function 'require' scripts/mainfunctions.lua(677,1) [00:00:14]: Disabling Michael (MICHAEL) because it had an error. [00:00:14]: Disabling Michael (MICHAEL) because it had an error. [00:00:14]: SCRIPT ERROR! Showing error screen [00:00:14]: Mod: Michael (MICHAEL) Registering default mod prefab [00:00:14]: ModIndex: Load sequence finished successfully. [00:00:14]: Reset() returning [00:00:14]: QueryServerComplete no callback [00:00:15]: QueryServerComplete no callback [00:00:16]: Force aborting... PLEASE HELP! I HAVE CHECKED THAT ANIM IS SPELLED CORRECTLY AND THAT michael.zip IS INSIDE IT, PLEASE HELP!!! michael.lua