revengeracer

  • Content count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About revengeracer

  • Rank
    Junior Member
  1. Sorry for my leave, I got Garry's Mod and forgot about life in general Got libmagick++-dev fine, did ./configure && make and here's what happened: will@will-OptiPlex-GX620:~$ cd Desktop/ktools-4.1.1will@will-OptiPlex-GX620:~/Desktop/ktools-4.1.1$ ./configure && make-- Detected CPU: generic-- Found ImageMagick: TRUE -- checking for module 'Magick++'-- found Magick++, version 6.8.9-- Looking for floor in m-- Looking for floor in m - found-- Looking for C++ include cstddef-- Looking for C++ include cstddef - found-- Looking for inttypes.h-- Looking for inttypes.h - found-- Looking for C++ include strstream-- Looking for C++ include strstream - found-- Looking for C++ include strstream.h-- Looking for C++ include strstream.h - not found-- Looking for C++ include sstream-- Looking for C++ include sstream - found-- Check size of long long-- Check size of long long - done-- Looking for snprintf-- Looking for snprintf - found-- Check size of mode_t-- Check size of mode_t - done-- Performing Test HAVE_RESTRICT-- Performing Test HAVE_RESTRICT - Failed-- Performing Test HAVE___RESTRICT-- Performing Test HAVE___RESTRICT - Success-- Configuring done-- Generating done-- Build files have been written to: /home/will/Desktop/ktools-4.1.1Scanning dependencies of target ktool_common[ 4%] Building CXX object CMakeFiles/ktool_common.dir/src/common/ktools_common.cpp.oIn file included from /home/will/Desktop/ktools-4.1.1/src/common/ktools_common.cpp:1:0:/home/will/Desktop/ktools-4.1.1/src/common/ktools_common.hpp:23:20: fatal error: config.h: No such file or directorycompilation terminated.make[2]: *** [CMakeFiles/ktool_common.dir/src/common/ktools_common.cpp.o] Error 1make[1]: *** [CMakeFiles/ktool_common.dir/all] Error 2make: *** [all] Error 2will@will-OptiPlex-GX620:~/Desktop/ktools-4.1.1$ ^Cwill@will-OptiPlex-GX620:~/Desktop/ktools-4.1.1$ What needs to be taken care of next, sir?
  2. Okay, I did try to uninstall and reinstall with apt-get but I was doing apt-get install imagemagick, not libmagic ++, but I got libmagick++ w/ apt-get, tried ./configure && make, and I'm still getting the same "can't find imagemagick" error as before. And you're right, I'm making this too hard, but I've only had Ubuntu for a few months and I'm still learning new tricks.
  3. Okay, we're getting somewhere, but now it's saying that it can't find image magick: will@will-OptiPlex-GX620:~$ cd Desktop/ktools-4.1.1will@will-OptiPlex-GX620:~/Desktop/ktools-4.1.1$ ./configure && make-- Detected CPU: genericCMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE): Could NOT find ImageMagick (missing: ImageMagick_FOUND)Call Stack (most recent call first): /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake-2.8/Modules/FindImageMagick.cmake:175 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) CMakeLists.txt:58 (FIND_PACKAGE) -- Configuring incomplete, errors occurred!will@will-OptiPlex-GX620:~/Desktop/ktools-4.1.1$ I followed the imagemagick instructions that were right on their website, and when I installed it DID say that it failed to install a couple brushes... These are the exact instructions I followed: http://www.imagemagick.org/script/install-source.php#unix I try to use ktech and the terminal says it can't find the command. Thanks for all your help! If I get this up and running, you'll be credited in my steam workshop
  4. Okay, so then I stayed in the Desktop/ktools-4.1.1 directory and did cmake and the terminal returned The program 'cmake' is currently not installed. You can install it by typing:sudo apt-get install cmake so I do sudo apt-get install cmake, and it says that cmake is already the newest version... I try cmake again and it does the exact same thing. I've done it a couple of times now, but it's an infinite loop of pain. Help please!
  5. Simplex, I'm trying to install ktools on my ubuntu 12.04 system, and I'm having some issues. I've got the latest version of image magick, which seems to have downloaded perfectly, as well as the latest version of cmake, which I got as a tarball, converted to .deb with alien, and installed from the software center. The issue that I'm having is when I get into the ktools directory (I just put the folder on my desktop and use cd Desktop/ktools-4.1.1, which works fine), and then I do ./configure && make, it returns this: ./configure: 3: exec: cmake: not found Just to experiment, I typed in ccmake, and the terminal returned this: The program 'ccmake' is currently not installed. You can install it by typing:sudo apt-get install cmake-curses-gui I did that, it said some packages couldn't be installed, and it returned this: The following packages have unmet dependencies:cmake-curses-gui : Depends: cmake (= 2.8.7-0ubuntu5) but 3.0.0-2 is to be installed I tried ccmake again but the same thing happened. Any resolve for this? Thank you!