Rtd

  • Content Count

    65
  • Joined

  • Last visited

Community Reputation

7 Neutral

About Rtd

  • Rank
    Junior Member
...

Badges

Recent Profile Visitors

591 profile views
  1. Can you try to join my test server (named TEST) to see if that work?
  2. Oops...My bad. So it's a problem of port forwarding. For some reason the clients packets can't reach your cave server on port 10990 (slave port). Make sure it is allowed in your firewall and fowarded by your router. Edit: In fact I dunno, since I noticed you need the Steam authentification to switch from one server to an other... Can't help you more on that sorry...
  3. Ok, so i've just replicated your setup on Windows and I have the same 'problem'. I didn't see that because I'm on Linux. But, even if on both servers I have this error: [Warning] SteamGameServer_Init Failedthe servers does work as intended. I can loggin and enter/leave the caves as I want!
  4. On both I presume... Are you sure dontstarve_dedicated_server_nullrenderer.exe is allowed in your firewall? And at this point, I assume you launched both servers with the batchs, right? Not through steam?
  5. The path provided by this line is wrong then: Locate were it is and replace what's inside the quotes, and retry.
  6. Ok, add pause at the end of the batch and duplicate it to make one for each server. Then launch them and you will able to see where the error is. Edit: Yes, that's why we are looking at something else.
  7. That's strange... It looks like a firewall problem but I'm not sure since you were able to launch it in it's default location... Can you try this batch (for both Master + Slave, AllInOne): ?
  8. That's not necessary a bad thing. ^^ Did you have your client opened while launching the servers?
  9. Thank you. Edit: Ok, so I don't see any error beside steam failing (again) to authenticate... What I suggest you, (if your are hosting and playing on the same machine), is first to separate you Master server directory from your game directory: Just copy the folder Klei/DoNotStarveTogether to Klei/DST for example. That will not hurt anyone. Then edit your command lines to the following: Master: Slave: Then make sure you are using the same server_token.txt in both Klei/DST and Klei/Caves_DST. Then (and last) use the settings I provided you in this post. Tell me if that changes anything.
  10. You posted 2 times the same log (the master one).
  11. Ok, taking a look at it. Edit: SLAVE_log.txt == MASTER_log.txt
  12. Are you playing and hosting on the same machine? (2 servers + 1 client?) Also, I don't know if this is a bug or what, or you forgot to replace Slave's settings.ini, but in Slave's log: which are the default ports of steam (already used by your master server).