crazy_xyr

  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

1 Neutral

About crazy_xyr

  • Rank
    Junior Member
...
  1. @Cairath If I use an archive structure, root must be the latest version number 。Is that right?
  2. When I tested the mod archive today, the lastWorkingBuild root is set to 0 and the archived_versions is set to 466654. Unable to load the beta mod contents correctly. The player.log file shows: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeLoadException: Could not resolve type with token 01000025 (from typeref, class/assembly Harmony.HarmonyInstance, 0Harmony, Version=1.2.0.1, Culture=neutral, PublicKeyToken=null) at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&) at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00032] in <695d1cc93cca45069c528c15c9fdd749>:0 --- End of inner exception stack trace --- at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00048] in <695d1cc93cca45069c528c15c9fdd749>:0 at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in <695d1cc93cca45069c528c15c9fdd749>:0 at KMod.DLLLoader.LoadUserModLoaderDLL () [0x00088] in C:\jenkins_workspace\workspace\SimGame_Windows\game\Assets\scripts\Mods\ModDLLLoader.cs:80 "Seems to have loaded the mod content in archive 466654 and got an error, not the beta mod content I wanted" . Is lastWorkingBuild 0 not available in Harmony2.0? Here is my mod_info.yaml MyOniMod/ |- mod_info.yaml | > supportedContent: ALL | > lastWorkingBuild: 0 | > version: "1.1.0" | > APIVersion: 2 |- (beta mod contents) |- archived_versions/ |- vanilla_pre_mergedown/ | |- mod_info.yaml | | > supportedContent: ALL | | > lastWorkingBuild: 466654 | |- (normal mod contents)
  3. lastWorkingBuild has been changed to lastWorkingVersion ?