H2ONotIncluded

  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About H2ONotIncluded

  • Rank
    Junior Member
...
  1. A crash occurs when I load my save file. It seems that it's about the logic broadcaster. Error in LogicInterasteroidReceiverComplete.LogicBroadcastReceiver.OnSpawn System.NullReferenceException: Object reference not set to an instance of an object at LogicPorts.GetInputValue (HashedString port_id) [0x00022] in C:\jenkins_workspace\workspace\Preview_Simgame_Windows\game\Assets\scripts\game\LogicPorts.cs:420 at LogicBroadcaster.GetCurrentValue () [0x00001] in C:\jenkins_workspace\workspace\Preview_Simgame_Windows\game\Assets\scripts\game\Buildings\LogicBroadcaster.cs:57 at LogicBroadcastReceiver.SyncWithBroadcast () [0x00045] in C:\jenkins_workspace\workspace\Preview_Simgame_Windows\game\Assets\scripts\game\Buildings\LogicBroadcastReceiver.cs:123 at LogicBroadcastReceiver.SetChannel (LogicBroadcaster broadcaster) [0x00087] in C:\jenkins_workspace\workspace\Preview_Simgame_Windows\game\Assets\scripts\game\Buildings\LogicBroadcastReceiver.cs:87 at LogicBroadcastReceiver.OnSpawn () [0x00020] in C:\jenkins_workspace\workspace\Preview_Simgame_Windows\game\Assets\scripts\game\Buildings\LogicBroadcastReceiver.cs:28 at KMonoBehaviour.Spawn () [0x00078] in C:\jenkins_workspace\workspace\Preview_Simgame_Windows\game\Assets\Plugins\Klei\util\KMonoBehaviour.cs:285 UnityEngine.Debug:LogError (object,UnityEngine.Object) Debug:LogError (object,UnityEngine.Object) (at C:/jenkins_workspace/workspace/Preview_Simgame_Windows/game/Assets/Plugins/Debug.cs:152) DebugUtil:LogErrorArgs (UnityEngine.Object,object[]) (at C:/jenkins_workspace/workspace/Preview_Simgame_Windows/game/Assets/Plugins/Klei/util/DebugUtil.cs:191) DebugUtil:LogException (UnityEngine.Object,string,System.Exception) (at C:/jenkins_workspace/workspace/Preview_Simgame_Windows/game/Assets/Plugins/Klei/util/DebugUtil.cs:201) KMonoBehaviour:Spawn () (at C:/jenkins_workspace/workspace/Preview_Simgame_Windows/game/Assets/Plugins/Klei/util/KMonoBehaviour.cs:292) KMonoBehaviour:Start () (at C:/jenkins_workspace/workspace/Preview_Simgame_Windows/game/Assets/Plugins/Klei/util/KMonoBehaviour.cs:243) Build: U35-478105-SD
  2. After building an oil well on oil reservoir, it comes to a crash when I dig or replace the block under the oil well. (I only test the block in the red circle, I don't know whether other blocks under the oil well have the same problem)