Lost Gremlin

  • Content count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Lost Gremlin

  • Rank
    Junior Member
  1. I have a colony that always crashes at the same moment. I can't find a cause in my base. It happens at the same point on different machines, both Windows and OS X. No crash dumps, but there are SimMessage log entries that allude to the cause. The exact log entries vary. I've seen four variants that always refer to temperature. Here's the relevant part of one log from a Windows game: [10:04:52.594] [3] [INFO] SimMessage: Assert failed: simData.updatedCells->temperature[cell] > 0.0f || simData.updatedCells->mass[cell] == 0.0f [10:04:52.594] [3] [INFO] c:\jenkins_workspace\workspace\release_simgame_windows\game\simdll\simlib\updatetemperature.cpp:159 c:\jenkins_workspace\workspace\release_simgame_windows\game\simdll\simlib\simupdate.cpp:131 c:\jenkins_workspace\workspace\release_simgame_windows\game\simdll\simlib\paralleltaskqueue.h:118 c:\program files (x86)\microsoft visual studio\2017\professional\vc\tools\msvc\14.16.27023\include\thr\xthread:230 c:\program files (x86)\microsoft visual studio\2017\professional\vc\tools\msvc\14.16.27023\include\thr\xthread:209 d:\th\minkernel\crts\ucrt\src\appcrt\startup\thread.cpp:115 [10:04:52.603] [3] [INFO] Submitting crash: And three different logs from Mac games: [09:50:46.625] [2] [INFO] SimMessage: Assert failed: simData.updatedCells->temperature[cell] > 0.0f || simData.updatedCells->mass[cell] == 0.0f [09:50:46.625] [2] [INFO] simlib/UpdateTemperature.cpp:159 Assert failure 'BREAKPT:' at simlib/UpdateTemperature.cpp(159) [21:20:29.757] [2] [INFO] SimMessage: Assert failed: cell.temperature() < SIM_MAX_TEMPERATURE [21:20:29.757] [2] [INFO] simlib/SimUtil.cpp:51 Assert failure 'BREAKPT:' at simlib/SimUtil.cpp(51) [10:12:07.944] [2] [INFO] SimMessage: Invalid temperature T=inf [10:12:07.944] [2] [INFO] simlib/UpdateTemperature.cpp:43 Assert failure 'BREAKPT:' at simlib/UpdateTemperature.cpp(43) Galaxy.sav
  2. Liquid textures are not shown

    I can confirm that this issue is fixed for me on the beta branch. Thanks!
  3. Graphics Failure on OS X 10.14.4

    Just verified that it also affects the Q3 beta.
  4. On OS X version 10.14.4 white squares show up and liquids aren't shown. This doesn't happen on 10.14.3.