• Announcements

    • JoeW

      Support Email Error (Zendesk)   08/12/2019

      We are migrating to a new customer support ticketing system (desk.com) and unfortunately while moving over our old tickets the new system (Zendesk) sent an auto reply to "new users". We weren't aware this would happen and so and email was sent out in error. You do not need to create an account and you can ignore the email entirely. You can find more info about this over on our forums here: https://forums.kleientertainment.com/forums/topic/110413-zendesk/ Sorry for the confusion

OneEyedGreenFox

  • Content count

    7
  • Joined

  • Last visited

 Content Type 

Profiles

Forums

Downloads

Klei Bug Tracker

Game Updates

Hot Lava Bug Reporter

Everything posted by OneEyedGreenFox

  1. My twitch drops, for this specific drop, has not been working, all my accounts steam, twitch and klei accounts are all properly linked. Every twitch drop has worked for me up until this point, i probably have over 2 hours on twitch and have not received anything. I tried switching from the beta to the base game but nothing is working.
  2. My twitch drops for this specific drop has not been working, all my accounts steam, twitch and klei accounts are all properly linked. Every twitch drop has worked for me up until this point, i probably have over 2 hours on twitch and have not received anything. I tried switching from the beta to the base game but nothing is working.

  3. The beta wont work for my friend, the drop down doesn't show the beta.
  4. The game has become slow when moving mouse and transitioning to a different page.
  5. Item collection problems

    I was looking on the curio cabinet of all the skins i have and it only shows the forge,hallows night, Christmas and vanilla skins. it doesn't show the skins i have gotten from twitch drops or the ones i have bought such as all the gorge collection or the pop figure skins. Another problem is that the profile icon doesn't show, it just the basic grey icon.
  6. Profile Icon not showing

    mine isn't showing