Sign in to follow this  

Can't Join Friend's "Friends Only" Server (PS5/4)


rabiddentite
  • Pending

Everytime I try to join my Friend's "Friends Only" Server, the game tells me that I can't join because I'm not the host's friend.

But the game does know we're friends, because it puts the hosted game at the top of the list when browsing. It also only shows that server when you filter it by "Friends".

This only started happening after the latest DST update AND the latest firmware update for PS4 and PS5. My friend is playing on PS4 and I'm playing on PS5, but we never had any issues before these 2 updates. We're both online (not appearing offline) and when you look at my friend's profile through the PS5 game base, it says that they are playing DST and are "joinable". I've tried joining through the game (browse games) and I've tried joining through PS5 game base. Both result in the same error message.

The PS5 firmware update did change something to the way friends and parties work, so maybe something was affected in terms of identifying who's a friend and who isn't.


Steps to Reproduce

Open DST

Go to Browse Games

See Friend's game at the top of the list, choose it and join the game

Message that server is set to Friends Only and that I am not a Friend of the host

Sign in to follow this  


User Feedback


My friends and I have had this problem for months.
Eventually we gave up and the work-around that we use is to make the server public, but require a password. 

Share this comment


Link to comment
Share on other sites

I think the same thing might have happened with me and my friend but I can’t be sure because it worked eventually so idk if I had this issue or if we did something wrong.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now