Sign in to follow this  

Game doesn't start on OSX


fredbird
  • Branch: Preview Branch Version: OSX Known Issue

Hi,

I could play the game a few hours ago, then stopped, and now it doesn't launch any more. I think i saw Steam update the client right before i tried to launch it but i'm not sure.

Player log is attached but the file seems unmodified by the crash.

Here is a capture of error message :

image.png.867695b5906a07caad167a6bd3ef5411.png

And here are my macbook specs :

image.png.6e8ddeb318e88a01f3b7672d42cbc20f.png

Is there any other information i could provide ?

 

 

Player.log


Steps to Reproduce

click on "launch game" on steam client.

Sign in to follow this  


User Feedback


@jambell, the same problem reports by me in wrong bug tracker, reinstalling doesn't help. 

 

BTW, I was dwelling in installation folder and I found something strange: there is second level of package and circular link:

2062344936_Screenshot2020-11-26at00_36_35.thumb.png.242b5f169de6abd4db47e4bd663d7a6a.png

 

I will try to remove everything manually and make fresh install.

Share this comment


Link to comment
Share on other sites

WORKAROUND
@jambell I've removed (/renamed) manually game folders ~/Library/Application Support/Steam/steamapps/common/OxygenNotIncluded and ~/Library/Application Support/unity.Klei.Oxygen Not Included, installed fresh game, uploaded saves from backup - and it works! Seems this circular reference could be a problem. Hope it helps you.

  • Thanks 2
  • Big Ups 1

Share this comment


Link to comment
Share on other sites

Had exactly the same issue immediately after updating the game yesterday. Steps I took:

- Restarted Steam - didn't work

- Restarted OS - didn't work

- Uninstalled the game, tried to run again - didn't work

- Read this post 

- Uninstalled again, removed contents from: (didn't backup savegames)

/Users/user/Library/Application Support/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded.app/Contents/

- The game now runs! (and the saved content seems to be in place)

image.png

image.png

Edited by skvizas
  • Thanks 1

Share this comment


Link to comment
Share on other sites

I've removed the game manually using terminal and rm -rf
then installed it again.

Now i receive an error on "black hole" screen.
error details:

 

 Error details
Texture has out of range width / height

at LoadScreen.SetPreview (System.String filename, System.String basename, UnityEngine.UI.Image preview, System.Boolean fallbackToTimelapse) [0x00000] in <51c03cea16464c98af38df13944d3113>:0
at LoadScreen.AddColonyToList (System.Collections.Generic.List`1[T] saves) [0x00000] in <51c03cea16464c98af38df13944d3113>:0
at LoadScreen.RefreshColonyList () [0x00000] in <51c03cea16464c98af38df13944d3113>:0
at LoadScreen.OnActivate () [0x00000] in <51c03cea16464c98af38df13944d3113>:0
at KScreen.Activate () [0x00000] in <004a61d0511e4ac7b1441f4919aa10df>:0
at LoadScreen.ShowMigrationIfNecessary (System.Boolean fromMainMenu) [0x00000] in <51c03cea16464c98af38df13944d3113>:0
at MainMenu.OnSpawn () [0x00000] in <51c03cea16464c98af38df13944d3113>:0
at KMonoBehaviour.Spawn () [0x00000] in <004a61d0511e4ac7b1441f4919aa10df>:0
at KMonoBehaviour.Start () [0x00000] in <004a61d0511e4ac7b1441f4919aa10df>:0

 

Share this comment


Link to comment
Share on other sites

Hi,

I unininstalled the game, reinstalled, the bug is still here.

I tried to unisntall, uncheck dlc, reinstall vanilla game, crashes too.

I will now try Nessumo workaround.

Share this comment


Link to comment
Share on other sites

If I may offer a work around that made my game stable again..

I just entered into steam files directly under Library section

go all the way into the ONI contents folder and put a copy of the ONI app into desktop

That fixed it for me.. since for some reason my whole desktop was erased from all icons.. and I thought maybe it was trying to recognize that change which wasn't available. Hope it helps anyone else.

Share this comment


Link to comment
Share on other sites

In my case, the issue appears to be the naming of the executable file inside the application package:

com.apple.xpc.launchd[1] (application.unity.Klei.Oxygen Not Included.2645056.25104727[46921]): Could not find and/or execute program specified by service: 2: No such file or directory: /Users/****/Library/Application Support/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded.app/Contents/MacOS/OxygenNotIncluded

Since the App is named "OxygenNotIncluded", Mac OS was looking for "..app folder blabla.../Contents/MacOS/OxygenNotIncluded" and not "...app folder blabla.../Contents/MacOS/Oxygen Not Included"

cp ~/Library/Application\ Support/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded.app/Contents/MacOS/Oxygen\ Not\ Included ~/Library/Application\ Support/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded.app/Contents/MacOS/OxygenNotIncluded

seems to have fixed it without restart or reinstall.

Edited by Unquiet Jake
Left people hanging with an unfinished sentence.

Share this comment


Link to comment
Share on other sites
On 12/1/2020 at 5:40 AM, Unquiet Jake said:

In my case, the issue appears to be the naming of the executable file inside the application package:


com.apple.xpc.launchd[1] (application.unity.Klei.Oxygen Not Included.2645056.25104727[46921]): Could not find and/or execute program specified by service: 2: No such file or directory: /Users/****/Library/Application Support/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded.app/Contents/MacOS/OxygenNotIncluded

Since the App is named "OxygenNotIncluded", Mac OS was looking for "..app folder blabla.../Contents/MacOS/OxygenNotIncluded" and not "...app folder blabla.../Contents/MacOS/Oxygen Not Included"


cp ~/Library/Application\ Support/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded.app/Contents/MacOS/Oxygen\ Not\ Included ~/Library/Application\ Support/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded.app/Contents/MacOS/OxygenNotIncluded

seems to have fixed it without restart or reinstall.

I have tried the command and the game immediately works afterwards. Thanks!

Share this comment


Link to comment
Share on other sites

For those on MacOS Catalina with the M1 chip, you have to go to the .app file (search Finder for Oxygen Not Included) then right click and press “Get Info” and click the box that says “Use Rosetta with this App”

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now