Sign in to follow this  

Game crashes on deconstructing solo nose cone

  • Branch: Preview Branch Version: Windows Pending

Game crashes on deconstructing and the error screen specifically has an error from removing interior world of the nosecone. I guess it doesn't like you deleting a world instance?

Steps to Reproduce

As soon as they deconstruct the Nose cone it crashes, every time.

Sign in to follow this  

User Feedback

Similar problem. The game crashed every time when I tried to deconstruct/replace but not the small but big habitat (10 pilot one). I tried to deconstruct everything inside. Still crashed. Reproduced multiple times!!! (every time I sent the report). I deconstructed the cone but was not able to destroy the habitat.

I could move it up and down but not deconstruct (both options were used for deconstruction with the same result - game crash).

The rocket came from another asteroid where it was constructed and I released the crew (no one was assigned).

I then assigned the same pilot and changed to replace the module to the small habitat and it worked!!! I loaded old saves I tried to reproduce the crash and I could not do it anymore!!! I went all way back when I have buildings inside the rocket and destroyed the module without any problem (tried both methods). I tried to destroy in focus and out of focus, I changed crews, did various things but could not repeat the crashes anymore!!!

It was like a path was broken and once a path was established the game repaired it and started working ok.

Share this comment

Link to comment
Share on other sites
On 12/8/2020 at 1:34 AM, catrue said:

This problem occurs due to the fact that there are resources in the module. Take everything out of the module and the error goes away.

No, it is not related to resources in the module. 

"I tried to deconstruct everything inside. Still crashed"

When (after playing with assigning pilots) I managed to deconstruct without the crash. I loaded the save file with building inside left and bins with resources and it deconstructed the habitat without any problems dropping all resources to the platform.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now