World layers visually messed up at every new cycle


ianawilson
  • Branch: Live Branch Version: OSX Pending

The first time I played this world, I didn't have any issues. Then, from my second play session onward, I've had a problem where every time a new cycle starts (and the autosave kicks in), the layers in the world get messed up. I observe the following problems:

  1. Many construction "blueprints" or plans are hidden behind the world
    502172490_ScreenShot2021-09-06at8_24_23PM.thumb.png.d9a7a345da2d0116ce665f33e2b18a84.png
  2. The oxygen and temperature overlays aren't visible
  3. The "fog" obscuring unknown areas is lifted and I can see everything in the world
  4. I can see red diagonal lines off the side of the map
    630852146_ScreenShot2021-09-06at8_24_36PM.thumb.png.bd4b8ec324abca3f2012daf8a8d4aeb1.png

The first item here is the most annoying because I'll forget where things are or not realize there's something pending construction.

A log of a session where I started up the game and immediately encountered the issue is attached, along with my save.

I've found that I can correct this issue by reloading the game. Also, at least once I've observed that it corrects itself on the next new cycle / auto save.

Computer specs:

  • MacBook Air (M1, 2020)
  • Chip: Apple M1
  • Memory: 8 GB
  • macOS Big Sur, version 11.2.3

Steps to Reproduce

Load my save and wait until a new cycle starts. The problem seems to happen after the auto-save is complete.

League Cycle 57.sav



User Feedback


There are some known compatibility issues between a subset of Mac integrated GPUs and the ONI engine, especially with M1 chips. It sounds like it happens when the timelapse screenshot is taken. Try disabling the timelapser and let me know if it still happens: Pause Menu -> Options -> Game -> Timelapse resolution (drag left to disable)

You can also try switching to glcore. This has helped solve other OSX M1 related issues.

1) In Steam, Right-click on ONI -> Properties

2) Under the General Tab, choose "Set Launch Options..."

3) In the text field, add "-force-glcore" -> Click OK

image_force_glcore.png

Share this comment


Link to comment
Share on other sites

Cool thanks for the reply. I just tried the timelapse option, and it still happened. I have to run, but I'll try the launch option change later.

Share this comment


Link to comment
Share on other sites

Hi apologies for the delay, the "-force-glcore" option helped! Just ran through 1 cycle and didn't hit this issue. I'll let you know if it comes up again.

  • Like 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now