Visual bug: The damage texture is everywhere


auraseer
  • Branch: Live Branch Version: Windows Fixed

I just loaded my most recent save, and was greeted with this. It looks like the "damage" texture, that is supposed to show up when a block is partially dug or damaged, is instead showing up everywhere.

In this screenshot there should be some generators, pumps, wires, pipes, and so on. Plus there's a volcano in the middle there, and some plants around the edges, which are also invisible. I note that liquids, critters, and floor debris can still be seen.

This screenshot is from right after reloading, before I restarted the clock, however it doesn't change when I let time run. It also doesn't change if I close and restart the whole game. 

20191002180059_1.jpg


Steps to Reproduce
I loaded a saved game

Status: Fixed

This issue has been fixed in either a future version or updated in a previous version.


  Report Bug


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
....

Changed Status to Known Issue

 

If you have a save game where it's happening every time on load, that'd be super useful (as most times it goes away on reload) @auraseer

  • Like 2

Share this comment


Link to comment
Share on other sites
....

If it helps any, I've noticed this flashing happens the most when I'm configuring settings like in a storage box.

As well as when Duplicants use buildings like the Pitcher Pump, to collect resources

Edited by Squeegee
Elaborating.

Share this comment


Link to comment
Share on other sites
....

I don't know if this helps, but i got this bug and for me it was related to the camera position (not zoom) as the broken texture on the bottom left disappeared when i scrolled down, it also appear to be limited on the lower bottom-left part of the screen, if this can help here there are a list of mod I used on this game file: FallingSand; LightningFastMenus; Bulk Settings Change; Show Area In Box Tool; Blueprints; Plan Buildings Without Materials; Bigger Camera Zoom Out; Geyser Calculated Avg Output Tooltip; Bigger Building Menu.
I'm also sending the save file even if when loaded the bug does not show.
 

 

 

klei3.thumb.PNG.9101d34f21ca637d086b01685c68dc56.PNGklei1.thumb.PNG.62e9f58745b4d12e875facd092eb1ebd.PNG5d95ebc161964_visualbug.thumb.png.4163ab63903b4512620603fbf2978ff1.png

visual bug.sav

Share this comment


Link to comment
Share on other sites
....

Thanks for the additional info and save files.
Worth noting that we do have a pretty good handle on what it is already!
 

Share this comment


Link to comment
Share on other sites
....

Changed Status to Fixed

The culprit has been found and will be detailed with a change log.

  • Thanks 3

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now