The game still claims that VC++2015 is not installed when it is


soapnrye
  • Pending

I've installed and re-installed VC++2015 couple times but had no luck. 

So I tried installing all Windows update even though SP1 was already there, updated my GPU driver and pretty much did all the thing in the troubleshooting guide but it still insist that I do not have VC installed. 

Any idea?

I'm running Windows 7 x64bit. And other specs are definitely higher than the requirement. 


Steps to Reproduce
Launched the game and pressed new game.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

Please do not be offended but did you pirate the game or did you buy it? Cause there was a bug in the game in a older version that caused this.

Share this comment


Link to comment
Share on other sites
....

Non-taken. That's a valid question.

But I bought the alpha from Steam. My game's current version number is 5.3.6.1367. 

Share this comment


Link to comment
Share on other sites
....

Ok now thats out of the way, can you upload this file  Steam\SteamApps\common\OxygenNotIncluded\OxygenNotIncluded_Data\output_log.txt

Share this comment


Link to comment
Share on other sites
.... .... .... ....

This is interesting ...

Failed to load 'C:/Program Files (x86)/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded_Data/Plugins/SimDLL.dll' with error '%1 is not a valid Win32 application.

Share this comment


Link to comment
Share on other sites
....

@soapnrye i had VC++ problem with a different game and only reinstalling the 2015 didnt solve it (tried multiple times), but removing all old VC++ and then reinstalling 2015 (32bit and 64bit) solved all my problems

Share this comment


Link to comment
Share on other sites
.... .... .... .... .... ....

@soapnrye well, my last long shot is, are you running steam as administrator? (there was a case earlier in bug report where admin right was the solution, tho it was win10)

Share this comment


Link to comment
Share on other sites
.... .... ....

I am glad I am not the only one with this problem. No matter what I do it won't work. I am on windows 8.1.

Share this comment


Link to comment
Share on other sites
....

I FOUND THE SOLUTION:

 

DELETE THIS FILE FROM THE GAME FOLDER  (\_CommonRedist\vcredist\2015\installscript.vdf)

is really weird because i think that folder has nothing to do with the game files. but i deleted this file and bingo! the error is gone

 

sry for my english

 

hope is work for you.

Share this comment


Link to comment
Share on other sites
.... ....

@SouzaZX @AlexRou And to whoever is following this thread still, I stumbled upon another thread who used to have the same problem as mine. I followed their method and it worked. And it was so simple that it baffled me for a sec. I had to uninstall and reinstall not just VC 2015 X64 but also VC 2015 X86 despite my OS being just 64bit. Once both of them were freshly installed and restarted, the game immediately ran.

Klei's troubleshoot guideline doesn't necessarily state that you need both which I think should be clarified. I was just gonna wait for next update or the official release until I decided to give it a go again today. 

Edited by soapnrye

Share this comment


Link to comment
Share on other sites
....
24 minutes ago, soapnrye said:

@SouzaZX @AlexRou And to whoever is following this thread still, I stumbled upon another thread who used to have the same problem as mine. I followed their method and it worked. And it was so simple that it baffled me for a sec. I had to uninstall and reinstall not just VC 2015 X64 but also VC 2015 X86 despite my OS being just 64bit. Once both of them were freshly installed and restarted, the game immediately ran.

Klei's troubleshoot guideline doesn't necessarily state that you need both which I think should be clarified. I was just gonna wait for next update or the official release until I decided to give it a go again today. 

Well @Blas88 said " i had VC++ problem with a different game and only reinstalling the 2015 didnt solve it (tried multiple times), but removing all old VC++ and then reinstalling 2015 (32bit and 64bit) solved all my problems "

And then you said " Just tried that. Did not solve the issue. :/ Dang it! "

So I assumed you installed the 32 bit version and the 64 bit version ...

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now