The game does not run on my computer


PurSun
  • Branch: Live Branch Version: Windows Pending

I purchased this game via steam six months ago, but I found that my laptop cannot run the official version!
I have tried reinstalling DX, VC ++, Windows and it still looks like this (This translation is from Google Translate)

我在半年前通过steam购买了这个游戏,但我发现我的笔记本电脑无法运行正式版本!
我已经尝试过重新安装DX、VC++、Windows都还是这个样子

ao.jpg


Steps to Reproduce

run game



User Feedback


.... ....

你好,我已经补上了文件。但我没有找到DMP 文件,这个文件也需要嘛?

Hi, I have made up the file. But I didn't find the DMP file. Is this file needed?

output_log.txt

Share this comment


Link to comment
Share on other sites
....

Hi, no need for the dmp file.

It appears that the game is having trouble loading resources. Can you try:

In Steam, right-click on Oxygen Not Included -> "Properties" -> "Local Files" -> "Verify Integrity of Local Files"

If that doesn't work, try disabling your mods. Since the game is crashing, you can't disable them from inside the game.

Look for this file and delete it (this is safe, it will be recreated by the game):

C:\Users\PurSun\Documents\Klei\OxygenNotIncluded\mods\mods.json

If that fixes it, one of the mods must be the issue.

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....

Hi, I have tried "Verify Integrity of Local Files" and unsubscribed all MODs and deleted mods.json. But unfortunately, the problem still appeared.:blue:

Share this comment


Link to comment
Share on other sites
.... .... ....

Interesting, this is quite mysterious. Here are few other ideas:

1) If you haven't already, try a complete uninstall in Steam and reinstall the game

2) If that doesn't work, go to Steam -> Right-click on ONI -> Local Files -> Browse Local Files
   Then navigate to -> OxygenNotIncluded_Data\StreamingAssets\elements\
   In this directory, there should be 4 .yaml files (you should see gas,solid,liquid, and special)
   Try deleting these files, I'd be curious to see if Windows complains when you attempt to delete them.
   After deleting these files, go back to Steam and re-do the "Verify Integrity of Local Files" (this will re-create those 4 files)

3) Finally, if the issue still persists, could you attach those 4 files here? Then I can take a look to see if there's an issue with the resource data

(edit: additional instructions in 2)

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now