strange lines and flickering after updating to OSX Catalina

  • Branch: Live Branch Version: OSX Known Issue

Playing from Steam, I started experiencing major lag which I assumed was related to the library update because other games like Graveyard Keeper were lagging for me, too. Even in small mode and with other settings enabled, I had issues.

Anyway, Steam support suggested I update my OS. I updated today from Mojave to Catalina (10.15.2), I'm on the newer MacBook Pro (15-inch, 2017), and now the game is unplayable due to graphics bugs.

I'm experiencing some strange lines and flickering appearing on my screen, it's kind of hard to describe.

  • Lines are black/multi-color and distort the screen entirely
  • Lines disappear when taking a screenshot or doing a screen recording
  • Issue happens consistently every time I open, obscures buttons and moves/flickers with and without mouse movement
  • Game is completely unplayable due to this 

I tried so far:

  • Rebooting, did make lines only appear on main screen instead of the Klei logo on launch
  • Reinstalling, no effect
  • Opening/closing Steam, no effect 
  • Tested other games, not seeing the same issue 

I see some people have experienced this issue in the past but no responses.

Help??? I play daily right now, and I'm on break. :(



Some things I've discovered:

  • Playing in windowed mode seems to eliminate the issue, but this isn't ideal
  • Swapping from windowed back to full screen still displays the issue
  • Using quicktime/screen recording to change the resolution temporarily worked, no longer working
  • Tabbing out of the game in full screen causes the issue to return
  • Going from windowed to full screen and back causes game to start lagging, requires restarting game
  • Noting the issue is still exclusive to ONI, no other steam games do this still

Steps to Reproduce
1. Updated to OSX Catalina 2. Open game via Steam client 3. Flickering begins on main screen, after logo
  • Like 1

User Feedback

Dunno if this will help you or not, but possible walk-around of this bug:

1. Go to Steam "Properties" of ONI

2. Local Files tab -> Browse local Files

3. Right click on ONI icon -> "Get Info"

4. Click on "Open in Low Resolution" checkbox and try to start game.


Hope this will help.

Share this comment

Link to comment
Share on other sites

I have it`s problem too on MacOS Catalina. 

I took this photo from my phone. The laptop takes a screenshot without lag.



P.S.:  I'm from Ukraine and my English is a little bad

Share this comment

Link to comment
Share on other sites

Same problem on Catalina.

Discovered that BATTLETECH has the same issue.

Low resolution setting does fix it

Edited by mikewl

Share this comment

Link to comment
Share on other sites

The update on the testing branch has a potential fix for the catalina compatibility issues. If you play on MacOS please test it out and let us know if you have any issues. Thanks!


  • Thanks 1

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now